php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63017 sapi/cli/php not build: Undefined symbol: php_register_internal_extension
Submitted: 2012-09-05 17:08 UTC Modified: 2021-06-12 22:04 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: lzsiga at freemail dot c3 dot hu Assigned: cmb (profile)
Status: Closed Package: Compile Failure
PHP Version: 5.4.6 OS: AIX-5.2
Private report: No CVE-ID: None
 [2012-09-05 17:08 UTC] lzsiga at freemail dot c3 dot hu
Description:
------------
There is a line in the main Makefile that defines how to create php.sym and sapi/cli/php

It goes like this:

BUILD_CLI = (generate php.sym from $(PHP_GLOBAL_OBJS) $(PHP_BINARY_OBJS) $(PHP_CLI_OBJS)) &&
(link executable sapi/php/cli from $(PHP_GLOBAL_OBJS) $(PHP_CLI_OBJS) etc)

The problem is $(PHP_BINARY_OBJS) that is in the first list, but not in the second. It either should be removed from the first list, or added to the second.

PS: Exactly the same goes for BUILD_CLI

PPS: The problem doesn't exist in 5.3.x


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-06-10 12:50 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2021-06-10 12:50 UTC] cmb@php.net
Is that still an issue with any of the actively supported PHP
versions[1]?

[1] <https://www.php.net/supported-versions.php>
 [2021-06-12 17:37 UTC] lzsiga at freemail dot c3 dot hu
I think it should be closed now as it has lost its relevance.
 [2021-06-12 22:04 UTC] cmb@php.net
-Status: Feedback +Status: Closed
 [2021-06-12 22:04 UTC] cmb@php.net
Thanks for the swift reply!
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Oct 23 15:03:34 2021 UTC