php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62970 Solr Response Empty from PHP, but Works in Browser or CURL?
Submitted: 2012-08-29 16:24 UTC Modified: 2014-02-13 20:52 UTC
From: fyb3roptik@php.net Assigned:
Status: Not a bug Package: solr (PECL)
PHP Version: 5.4.6 OS: Debian 6
Private report: No CVE-ID: None
 [2012-08-29 16:24 UTC] fyb3roptik@php.net
Description:
------------
Please see this article:

http://e-mats.org/2011/10/solr-response-empty-from-php-but-works-in-browser-or-
curl/

This is happening for me. I can login to solr admin and run the query and get 1 
result, but if I run it through this extension it says numfound is 1, but docs is 
false (empty).

Expected result:
----------------
If numfound is 1 I expect to get that 1 doc

Actual result:
--------------
Numfound is 1, but docs is empty

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-08-30 06:00 UTC] fyb3roptik@php.net
For anyone having this issue. Check start_num. It should be set to 0 and not 1
 [2012-09-26 19:31 UTC] eric dot caron at gmail dot com
I'd love to crank out the fix for this, fy3roptik, namely the sample code you're invoking for SolrQuery and SolrClient. Based on Lucene/Solr spec, start_num should be 0 (as you mentioned on 2012-08-30) but I'm expecting you left this bug open because the default isn't right (which I need an assist on reproducing.)
 [2012-10-21 04:04 UTC] fyb3roptik@php.net
Go ahead and close it. It was user error =)
 [2014-02-13 20:52 UTC] omars@php.net
-Status: Open +Status: Not a bug
 [2014-02-13 20:52 UTC] omars@php.net
This have to do with the 'start' parameter, which defaults to 0. on the solr server.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 08:01:23 2020 UTC