php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62899 Greek Locale Error
Submitted: 2012-08-22 20:22 UTC Modified: 2012-08-22 20:44 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: christos_97 at hotmail dot gr Assigned:
Status: Not a bug Package: Strings related
PHP Version: 5.3.15 OS: Linux
Private report: No CVE-ID: None
 [2012-08-22 20:22 UTC] christos_97 at hotmail dot gr
Description:
------------
I have installed a script (IP.Board) on my hosting account and i translated it in 
Greek. For locale, I used el_GR.UTF-8. Everything is working perfect except the 
currencies. For example, if I use IP.Nexus and add a package(item) for 1,99, it 
will display 1,9900. Every time it get a currency, it adds two zeros in the end.

Image: http://community.invisionpower.com/uploads/monthly_08_2012/ccs-369978-0-
34198700-1345658909_thumb.png

I contacted Invision Power and they told me to contact my hosting provider. Then, 
i contacted my hosting provider and they told me to contact a skilled PHP 
developer. So here I am. I want to know if this is an error of php and a way to 
fix it, or if this a fault of my hosting provider.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-08-22 20:28 UTC] christos_97 at hotmail dot gr
-PHP Version: 5.3.16 +PHP Version: 5.3.15
 [2012-08-22 20:28 UTC] christos_97 at hotmail dot gr
Description:
------------
I have installed a script (IP.Board) on my hosting account and i translated it 
in 
Greek. For locale, I used el_GR.UTF-8. Everything is working perfect except the 
currencies. For example, if I use IP.Nexus and add a package(item) for 1,99, it 
will display 1,9900. Every time it get a currency, it adds two zeros in the end.

Image: http://www.thegamelounge.net/uploads/bug.png

I contacted Invision Power and they told me to contact my hosting provider. 
Then, 
i contacted my hosting provider and they told me to contact a skilled PHP 
developer. So here I am. I want to know if this is an error of php and a way to 
fix it, or if this a fault of my hosting provider.
 [2012-08-22 20:44 UTC] cataphract@php.net
Sorry, this is not a support forum. Try the users mailing list.
 [2012-08-22 20:44 UTC] cataphract@php.net
-Status: Open +Status: Not a bug
 [2012-08-23 01:16 UTC] christos_97 at hotmail dot gr
Yeap. After a little more search, i found that this is not a bug. Although it is 
something that you should change in the feature. The el_GR, el_CY etc should have 
int_frac_digits and frac_digits at two like every other locale has. I need to know 
how to manually change those (int_frac_digits and frac_digits) via a php file 
also. thanks
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 26 08:01:24 2020 UTC