php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62886 PHP-FPM may segfault/hang on startup
Submitted: 2012-08-22 08:26 UTC Modified: 2012-09-26 19:31 UTC
Votes:29
Avg. Score:4.9 ± 0.3
Reproduced:28 of 28 (100.0%)
Same Version:13 (46.4%)
Same OS:10 (35.7%)
From: pierre at archlinux dot de Assigned: fat
Status: Closed Package: FPM related
PHP Version: 5.4.6 OS: Arch Linux
Private report: No CVE-ID:
 [2012-08-22 08:26 UTC] pierre at archlinux dot de
Description:
------------
Since PHP 5.4.5 starting php-fpm will either result in a segmentation fault or it will hang under certain conditions.

It is a little hard to reproduce but it seems it is related to using modules. There more modules get loaded via php.ini the more likely this bug will get triggered (> 30%); with no modules loaded I was not able to trigger it.

I started from 5.4.6 and reverted patches applied to sapi/fpm. Once I reverted commit c2f33fb1293cbcdc94daefb8583ca13e98b5c826, php would no longer crash or hang.

See http://git.php.net/?p=php-src.git;a=commit;h=c2f33fb1293cbcdc94daefb8583ca13e98b5c826

Test script:
---------------
Configure php with a bunch of modules and run something like this:

for i in {1..100};do sudo php-fpm;sleep 0.5;sudo killall php-fpm;sleep 0.5;done

watch dmesg for segfaults like

php-fpm[32571]: segfault at 7f4eabe93cf8 ip 00007f4eae9b1ed6 sp 00007fff87d69310 error 4 in ld-2.16.so[7f4eae9a3000+21000]

gdb will tell you 0x00007fe0412c1ed6 in _dl_fini () from /lib/ld-linux-x86-64.so.2

Sometimes php-fpm will hang and has to be killed with kill -9.


Patches

bug62886.patch.txt (last revision 2012-09-26 19:28 UTC) by fat@php.net)
php-fpm.conf (last revision 2012-08-24 08:56 UTC) by pierre at archlinux dot de)
php.ini (last revision 2012-08-24 08:55 UTC) by pierre at archlinux dot de)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-08-23 15:41 UTC] laruence@php.net
-Assigned To: +Assigned To: fat
 [2012-08-23 15:41 UTC] laruence@php.net
fat, could you please look at this one?
 [2012-08-23 22:55 UTC] fat@php.net
-Status: Assigned +Status: Feedback
 [2012-08-23 22:55 UTC] fat@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.

COuld you please provide the full backtrace please ?

if it's possible, it would be great to enable debug symbols at compilation time

thx
 [2012-08-24 08:37 UTC] pierre at archlinux dot de
-Status: Feedback +Status: Assigned
 [2012-08-24 08:37 UTC] pierre at archlinux dot de
I rebuild with debug symbols and got the following trace:

Core was generated by `php-fpm'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007fc96b2c6ed6 in _dl_fini () from /lib/ld-linux-x86-64.so.2
(gdb) bt
#0  0x00007fc96b2c6ed6 in _dl_fini () from /lib/ld-linux-x86-64.so.2
#1  0x00007fc96970cb31 in __run_exit_handlers () from /lib/libc.so.6
#2  0x00007fc96970cbb5 in exit () from /lib/libc.so.6
#3  0x00000000008cb754 in fpm_signals_sighandler_exit_ok (pid=10) at /build/src/php-5.4.6/sapi/fpm/fpm/fpm_signals.c:254
#4  <signal handler called>
#5  0x00007fc96b2cf3c7 in munmap () from /lib/ld-linux-x86-64.so.2
#6  0x00007fc96b2ceb4d in _dl_unmap () from /lib/ld-linux-x86-64.so.2
#7  0x00007fc96b2cba1f in _dl_close_worker () from /lib/ld-linux-x86-64.so.2
#8  0x00007fc96b2cc18c in _dl_close () from /lib/ld-linux-x86-64.so.2
#9  0x00007fc96b2c6736 in _dl_catch_error () from /lib/ld-linux-x86-64.so.2
#10 0x00007fc969fee5fc in ?? () from /lib/libdl.so.2
#11 0x00007fc969fee10f in dlclose () from /lib/libdl.so.2
#12 0x0000000000773e2c in module_destructor (module=0x1ba6050) at /build/src/php-5.4.6/Zend/zend_API.c:2284
#13 0x000000000077c30f in zend_hash_apply_deleter (ht=0xfb5240 <module_registry>, p=0x1ba5ff0) at /build/src/php-5.4.6/Zend/zend_hash.c:650
#14 0x000000000077c4aa in zend_hash_graceful_reverse_destroy (ht=0xfb5240 <module_registry>) at /build/src/php-5.4.6/Zend/zend_hash.c:687
#15 0x0000000000771f97 in zend_destroy_modules () at /build/src/php-5.4.6/Zend/zend_API.c:1797
#16 0x0000000000768e9e in zend_shutdown () at /build/src/php-5.4.6/Zend/zend.c:823
#17 0x00000000006d5151 in php_module_shutdown () at /build/src/php-5.4.6/main/main.c:2346
#18 0x00000000008c7e23 in fpm_php_cleanup (which=2, arg=0x0) at /build/src/php-5.4.6/sapi/fpm/fpm/fpm_php.c:199
#19 0x00000000008bc629 in fpm_cleanups_run (type=2) at /build/src/php-5.4.6/sapi/fpm/fpm/fpm_cleanup.c:45
#20 0x00000000008cf1df in fpm_unix_init_main () at /build/src/php-5.4.6/sapi/fpm/fpm/fpm_unix.c:312
#21 0x00000000008bb2df in fpm_init (argc=1, argv=0x7fff252a4a98, config=0x0, prefix=0x0, pid=0x0, test_conf=0, run_as_root=0) at /build/src/php-5.4.6/sapi/fpm/fpm/fpm.c:59
#22 0x00000000008c7221 in main (argc=1, argv=0x7fff252a4a98) at /build/src/php-5.4.6/sapi/fpm/fpm/fpm_main.c:1800
 [2012-08-24 08:46 UTC] fat@php.net
-Status: Assigned +Status: Feedback
 [2012-08-24 08:46 UTC] fat@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.


I also need your FPM configuration and your php.ini please

thanks
 [2012-08-24 09:06 UTC] pierre at archlinux dot de
-Status: Feedback +Status: Assigned
 [2012-08-24 09:06 UTC] pierre at archlinux dot de
I have attached php.ini and php-fpm.conf as patches (sorry, didn't fint another way to attach those)

Here is what is different from the configuration shipped with PHP 5.4.6:

The php-fpm.conf is the plain upstream one with this patch applied: https://projects.archlinux.de/svntogit/packages.git/tree/trunk/php-fpm.conf.in.patch?h=packages/php

php.ini is a copy of php.ini-production with this patch applied: https://projects.archlinux.de/svntogit/packages.git/tree/trunk/php.ini.patch?h=packages/php

On top of that I applied the following changes locally: http://paste.xinu.at/Hp6/
 [2012-09-12 16:32 UTC] jeffrey dot ness at rackspace dot com
I am also noticing this issue with our 5.3.16 packages:

# php-fpm -v
PHP 5.3.16 (fpm-fcgi) (built: Aug 20 2012 10:39:20)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies

# for i in {1..100}; do php-fpm ; killall php-fpm; done
Segmentation fault
Segmentation fault
Segmentation fault

# dmesg | grep php-fpm
php-fpm[30800]: segfault at 7f7d199f4cd0 ip 00007f7d24a43b83 sp 00007fffdd48fb20 error 4 in ld-
2.12.so[7f7d24a35000+20000]
php-fpm[31599]: segfault at 7f50f17c3cd0 ip 00007f50fc812b83 sp 00007fff09f13120 error 4 in ld-
2.12.so[7f50fc804000+20000]
php-fpm[32009]: segfault at 7f3005f59cc0 ip 00007f3010938b83 sp 00007fffb291c3a0 error 4 in ld-
2.12.so[7f301092a000+20000]
php-fpm[32313]: segfault at 7f17094a4cc0 ip 00007f1713e83b83 sp 00007fffaab94e20 error 4 in ld-
2.12.so[7f1713e75000+20000]
php-fpm[32585]: segfault at 7f60ad427cc0 ip 00007f60b7e06b83 sp 00007ffff44e06a0 error 4 in ld-
2.12.so[7f60b7df8000+20000]
 [2012-09-17 09:55 UTC] daniel at bashgeek dot net
Have the same problem on my end with a couple of servers. For me the problem is solved as soon as I disable the IMAP extension of PHP. Maybe it has something todo with this extension?
 [2012-09-17 09:59 UTC] pierre at archlinux dot de
It also crashes with the imap extension disabled. But it seems the number of enabled extensions might matter.

Anyway, we have a backtrace and the commit that introduced this issue.
 [2012-09-20 10:40 UTC] hsatac at golang dot tw
Having the same issue.
Archlinux + PHP 5.4.7
 [2012-09-26 19:28 UTC] fat@php.net
The following patch has been added/updated:

Patch Name: bug62886.patch.txt
Revision:   1348687704
URL:        https://bugs.php.net/patch-display.php?bug=62886&patch=bug62886.patch.txt&revision=1348687704
 [2012-09-26 19:31 UTC] fat@php.net
Can you please test the following path ?

The commit you mentioned to be faulty in fact did the following things:
when daemonize, the calling process waited 10s for the master process (which 
have been forked just before) to send USR1 if OK or USR2 otherwise.

There must be a problem with some external libraries using USR1 and USR2.

I've removed the signal stuff and have it replaced by a pipe(2). 

Can you please test and tell me if it fix your problem (which I never been able 
to reproduce on my side).

thx
++ fat
 [2012-09-26 19:31 UTC] fat@php.net
-Status: Assigned +Status: Feedback
 [2012-09-26 20:26 UTC] jonas at brachium-system dot net
I came from #62954 - I have applied your patch against 5.3.x source.

It fixes my problem - fpm starts up normal and detaches.

fat, great work :)
 [2012-09-27 18:51 UTC] jdr at alexanderinteractive dot com
This patch seems to do the trick for me for php 5.4.7

Thanks!
 [2012-09-27 22:08 UTC] fat@php.net
Automatic comment on behalf of fat
Revision: http://git.php.net/?p=php-src.git;a=commit;h=75c63c5503b1c6b72e5e1daf5b4bfd02c68a4b79
Log: - Fixed bug #62954 (startup problems fpm / php-fpm) - Fixed bug #62886 (PHP-FPM may segfault/hang on startup)
 [2012-09-27 22:08 UTC] fat@php.net
-Status: Feedback +Status: Closed
 [2012-09-27 22:08 UTC] fat@php.net
Automatic comment on behalf of fat
Revision: http://git.php.net/?p=php-src.git;a=commit;h=b5eb1456aa17e83b7b734dfc2316d632c9adcc6c
Log: - Fixed bug #62954 (startup problems fpm / php-fpm) - Fixed bug #62886 (PHP-FPM may segfault/hang on startup)
 [2012-09-27 22:55 UTC] fat@php.net
Automatic comment on behalf of fat
Revision: http://git.php.net/?p=php-src.git;a=commit;h=75c63c5503b1c6b72e5e1daf5b4bfd02c68a4b79
Log: - Fixed bug #62954 (startup problems fpm / php-fpm) - Fixed bug #62886 (PHP-FPM may segfault/hang on startup)
 [2012-09-28 18:34 UTC] per at techspot dot com
fat: you can probably link this fix to bug #62937 aswell.
APC is listed in that bug report, but any opcode cacher just makes this problem with php-fpm surface more regularly due to the increased concurrency...
Thanks for the fix! (I'll wait for it's inclusion in the next PHP release though)
 [2012-09-29 05:35 UTC] fat@php.net
done !
 [2012-10-02 17:19 UTC] per at techspot dot com
Confirmed working on my testserver, thank you!
The patch has already been backported into remi's repository, both v5.4 & v5.3
http://rpms.famillecollet.com/enterprise/6/remi/x86_64/repoview/php.html
 [2012-10-09 14:42 UTC] slim at inbox dot lv
still same problem with the patch on high loaded php.
in logs:
[09-Oct-2012 03:11:40] NOTICE: Reloading in progress ...
[09-Oct-2012 03:11:40] ERROR: unable to read what child say: Bad file descriptor (9)
[09-Oct-2012 03:11:40] ERROR: unable to read what child say: Bad file descriptor (9)
[09-Oct-2012 03:11:40] ERROR: unable to read what child say: Bad file descriptor (9)
 [2012-10-23 12:23 UTC] slim at inbox dot lv
did some another tests on other kernel and patch looks fine for me too
 [2013-03-19 12:28 UTC] anonymousdude at gmail dot com
[19-Mar-2013 08:22:54] NOTICE: Reloading in progress ...
[19-Mar-2013 08:22:54] ERROR: unable to read what child say: Bad file descriptor 
(9)
[19-Mar-2013 08:22:54] ERROR: unable to read what child say: Bad file descriptor 
(9)
[19-Mar-2013 08:22:54] ERROR: unable to read what child say: Bad file descriptor 
(9)
[19-Mar-2013 08:22:54] ERROR: unable to read what child say: Bad file descriptor 
(9)
[19-Mar-2013 08:22:54] ERROR: unable to read what child say: Bad file descriptor 
(9)
[19-Mar-2013 08:22:54] ERROR: unable to read what child say: Bad file descriptor 
(9)
[19-Mar-2013 08:22:54] NOTICE: reloading: execvp("php-fpm", {"php-fpm", "--
daemonize"})
[19-Mar-2013 08:22:55] NOTICE: using inherited socket fd=7, "127.0.0.1:9000"
[19-Mar-2013 08:22:55] NOTICE: using inherited socket fd=7, "127.0.0.1:9000"
[19-Mar-2013 08:22:55] NOTICE: fpm is running, pid 25134
[19-Mar-2013 08:22:55] NOTICE: ready to handle connections
[root@ID11878 php-fpm]#
[root@ID11878 php-fpm]# php -v
PHP 5.4.13 (cli) (built: Mar 14 2013 08:57:49)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies
 [2013-04-04 20:42 UTC] zakrzewskim at wp dot pl
Same to me:

[04-Apr-2013 22:38:37] ERROR: unable to read what child say: Bad file descriptor (9)
[04-Apr-2013 22:38:55] ERROR: unable to read what child say: Bad file descriptor (9)
[04-Apr-2013 22:38:55] ERROR: unable to read what child say: Bad file descriptor (9)
[04-Apr-2013 22:38:55] ERROR: unable to read what child say: Bad file descriptor (9)
[04-Apr-2013 22:38:55] ERROR: unable to read what child say: Bad file descriptor (9)
[04-Apr-2013 22:38:55] ERROR: unable to read what child say: Bad file descriptor (9)
[04-Apr-2013 22:38:55] ERROR: unable to read what child say: Bad file descriptor (9)

php-fpm[19644]: segfault at 7fff30199fe0 ip 0000000000574e30 sp 00007fff30199fb0 error 6 in php-fpm[400000+32a000]
php-fpm[18003]: segfault at 7fff30199fe0 ip 0000000000574e30 sp 00007fff30199fb0 error 6 in php-fpm[400000+32a000]
php-fpm[9699]: segfault at 7fff30199fe0 ip 0000000000574e30 sp 00007fff30199fb0 error 6 in php-fpm[400000+32a000]
php-fpm[17649]: segfault at 7fff30199fe0 ip 0000000000574e30 sp 00007fff30199fb0 error 6 in php-fpm[400000+32a000]
php-fpm[13203]: segfault at 7fff30199fe0 ip 0000000000574e30 sp 00007fff30199fb0 error 6 in php-fpm[400000+32a000]
php-fpm[21313]: segfault at 7ffeff931fa0 ip 0000000000574e30 sp 00007ffeff931f70 error 6 in php-fpm[400000+32a000]
php-fpm[4705]: segfault at 7fff84be5fa0 ip 0000000000574e30 sp 00007fff84be5f70 error 6 in php-fpm[400000+32a000]
php-fpm[24508]: segfault at 7fff84be5fa0 ip 0000000000574e30 sp 00007fff84be5f70 error 6 in php-fpm[400000+32a000]

[root@onlinecity /]# php -v
PHP 5.4.13 (cli) (built: Mar 14 2013 09:15:29)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies
    with the ionCube PHP Loader v4.2.2, Copyright (c) 2002-2012, by ionCube Ltd., and
    with SourceGuardian v9.0.4, Copyright (c) 2000-2012, by Inovica Ltd.

rpm -qi php
Name        : php                          Relocations: (not relocatable)
Version     : 5.4.13                            Vendor: Remi Collet
Release     : 1.el5.remi                    Build Date: czw 14 mar 2013 09:27:38 CET
Install Date: sob 16 mar 2013 18:44:01 CET      Build Host: dixsept.famillecollet.com
Group       : Development/Languages         Source RPM: php-5.4.13-1.el5.remi.src.rpm
Size        : 9294225                          License: PHP and Zend and BSD
Signature   : DSA/SHA1, czw 14 mar 2013 09:45:45 CET, Key ID 004e6f4700f97f56
Packager    : http://blog.famillecollet.com/
URL         : http://www.php.net/
Summary     : Osadzany w HTML-u język skryptowy PHP (PHP: preprocesor hipertekstu).
Description :
PHP is an HTML-embedded scripting language. PHP attempts to make it
easy for developers to write dynamically generated webpages. PHP also
offers built-in database integration for several commercial and
non-commercial database management systems, so writing a
database-enabled webpage with PHP is fairly simple. The most common
use of PHP coding is probably as a replacement for CGI scripts.

The php package contains the module which adds support for the PHP
language to Apache HTTP Server.
 [2013-04-10 06:30 UTC] chanda at lusakatimes dot com
Me too

Running on Freebsd  9.1 (64 bit) 

$php -v
PHP 5.4.13 (cli) (built: Mar 27 2013 21:17:00) (DEBUG)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies

$ php-fpm -v
PHP 5.4.13 (fpm-fcgi) (built: Mar 27 2013 21:17:01) (DEBUG)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies
 [2013-05-06 09:24 UTC] ck at claudiokuenzler dot com
Me three. Happens on SmartOS joyent_20120614T184600Z with PHP 5.3.10.

# php -v
PHP 5.3.10 (cli) (built: Mar 25 2012 13:30:23) 
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
    with Suhosin v0.9.33, Copyright (c) 2007-2012, by SektionEins GmbH

# php-fpm -v
PHP 5.3.10 (fpm-fcgi) (built: Mar 25 2012 15:17:24)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
    with Suhosin v0.9.33, Copyright (c) 2007-2012, by SektionEins GmbH

php-fpm.log:
[06-May-2013 11:12:40] NOTICE: fpm is running, pid 12244
[06-May-2013 11:12:41] NOTICE: ready to handle connections
[06-May-2013 11:16:11] NOTICE: Reloading in progress ...
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)
[06-May-2013 11:16:11] ERROR: unable to read what child say: Bad file number (9)

PHP-FPM dies then and Apache returns a "Internal Server error" page.
 [2013-09-28 16:32 UTC] toktikweb at gmail dot com
Same me on high load.

Software version:
FreeBSD 8.3
PHP 5.4.19 (fpm-fcgi)

[28-Sep-2013 20:19:31] ERROR: unable to read what child say: Bad file descriptor 
(9)
[28-Sep-2013 20:19:31] ERROR: unable to read what child say: Bad file descriptor 
(9)
[28-Sep-2013 20:19:31] ERROR: unable to read what child say: Bad file descriptor 
(9)
[28-Sep-2013 20:20:51] ERROR: unable to read what child say: Bad file descriptor 
(9)
[28-Sep-2013 20:20:51] ERROR: unable to read what child say: Bad file descriptor 
(9)
[28-Sep-2013 20:25:05] ERROR: unable to read what child say: Bad file descriptor 
(9)
[28-Sep-2013 20:25:05] ERROR: unable to read what child say: Bad file descriptor 
(9)
[28-Sep-2013 20:25:05] ERROR: unable to read what child say: Bad file descriptor 
(9)
[28-Sep-2013 20:25:05] ERROR: unable to read what child say: Bad file descriptor 
(9)
[28-Sep-2013 20:25:52] ERROR: unable to read what child say: Bad file descriptor 
(9)

/var/log/messages for that period
Sep 28 20:00:20 <kern.info> ex11 kernel: pid 34096 (php-fpm), uid 80: exited on 
signal 11 (core dumped)
Sep 28 20:06:54 <kern.info> ex11 kernel: pid 34998 (php-fpm), uid 80: exited on 
signal 10 (core dumped)
Sep 28 20:08:15 <kern.info> ex11 kernel: pid 35009 (php-fpm), uid 80: exited on 
signal 10 (core dumped)
Sep 28 20:19:10 <kern.info> ex11 kernel: pid 36656 (php-fpm), uid 80: exited on 
signal 10 (core dumped)

Backtrace:
#0  0x0000000000696070 in ZEND_FETCH_CONSTANT_SPEC_VAR_CONST_HANDLER 
(execute_data=0x801826cb0) at zend_vm_execute.h:13709
#1  0x0000000000671970 in execute (op_array=0x80e205240) at 
zend_vm_execute.h:410
#2  0x0000000000627c9e in zend_call_function (fci=0x7fffffffbe70, 
fci_cache=0x7fffffffbe00)
    at /usr/ports/lang/php5/work/php-5.4.19/Zend/zend_execute_API.c:956
#3  0x00000000006599ff in zend_call_method (object_pp=0x80e23a130, 
obj_ce=0x80e204630, fn_proxy=0x80e23a128, 
    function_name=0x80e2088b0 "zend_loader_standardautoloader::autoload\001", 
function_name_len=45, retval_ptr_ptr=0x7fffffffbf88, param_count=1, 
    arg1=0x80e4f63b8, arg2=0x0) at /usr/ports/lang/php5/work/php-
5.4.19/Zend/zend_interfaces.c:97
#4  0x0000000000483a98 in zif_spl_autoload_call (ht=1, return_value=0x80e4f61e0, 
return_value_ptr=0x7fffffffc270, this_ptr=0x0, return_value_used=1)
    at /usr/ports/lang/php5/work/php-5.4.19/ext/spl/php_spl.c:436
#5  0x0000000000627e5f in zend_call_function (fci=0x7fffffffc220, 
fci_cache=0x7fffffffc1f0)
    at /usr/ports/lang/php5/work/php-5.4.19/Zend/zend_execute_API.c:978
#6  0x0000000000628829 in zend_lookup_class_ex (name=0x804fd11f0 "Zend_Cache", 
name_length=10, key=0x80e4b7388, use_autoload=1, ce=0x7fffffffc360)
    at /usr/ports/lang/php5/work/php-5.4.19/Zend/zend_execute_API.c:1125
#7  0x0000000000629713 in zend_fetch_class_by_name (class_name=0x804fd11f0 
"Zend_Cache", class_name_len=10, key=0x80e4b7388, fetch_type=0)
    at /usr/ports/lang/php5/work/php-5.4.19/Zend/zend_execute_API.c:1605
#8  0x000000000067af1e in ZEND_FETCH_CONSTANT_SPEC_CONST_CONST_HANDLER 
(execute_data=0x801826150) at zend_vm_execute.h:3600
#9  0x0000000000671970 in execute (op_array=0x80e4bef80) at 
zend_vm_execute.h:410
#10 0x0000000000627c9e in zend_call_function (fci=0x7fffffffc640, 
fci_cache=0x7fffffffc4b0)
    at /usr/ports/lang/php5/work/php-5.4.19/Zend/zend_execute_API.c:956
#11 0x000000000062706a in call_user_function_ex (function_table=0x80185e060, 
object_pp=0x0, function_name=0x80e6ec0b0, retval_ptr_ptr=0x7fffffffc6e8, 
    param_count=2, params=0x80e4f6d68, no_separation=1, symbol_table=0x0) at 
/usr/ports/lang/php5/work/php-5.4.19/Zend/zend_execute_API.c:748
#12 0x0000000000626ecd in call_user_function (function_table=0x80185e060, 
object_pp=0x0, function_name=0x80e6ec0b0, retval_ptr=0x80e4f7278, param_count=2, 
    params=0x7fffffffc780) at /usr/ports/lang/php5/work/php-
5.4.19/Zend/zend_execute_API.c:721
#13 0x000000080443768f in ps_call_handler () from /usr/local/lib/php/20100525-
debug/session.so
#14 0x0000000804437d64 in ps_write_user () from /usr/local/lib/php/20100525-
debug/session.so
#15 0x000000080442d5f1 in php_session_save_current_state () from 
/usr/local/lib/php/20100525-debug/session.so
#16 0x00000008044323d6 in php_session_flush () from /usr/local/lib/php/20100525-
debug/session.so
#17 0x00000008044342a9 in zm_deactivate_session () from 
/usr/local/lib/php/20100525-debug/session.so
#18 0x0000000000644211 in zend_deactivate_modules () at 
/usr/ports/lang/php5/work/php-5.4.19/Zend/zend_API.c:2370
#19 0x00000000005b1b5a in php_request_shutdown (dummy=0x0) at 
/usr/ports/lang/php5/work/php-5.4.19/main/main.c:1772
#20 0x00000000006e8156 in main (argc=1, argv=0x7fffffffed30) at 
/usr/ports/lang/php5/work/php-5.4.19/sapi/fpm/fpm/fpm_main.c:1961
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 23:01:58 2014 UTC