php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62780 Warning: Cannot modify header information
Submitted: 2012-08-08 13:22 UTC Modified: 2012-08-08 20:44 UTC
From: info at businesscanvas dot in Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.4.5 OS: win7
Private report: No CVE-ID: None
 [2012-08-08 13:22 UTC] info at businesscanvas dot in
Description:
------------
Warning: Cannot modify header information 


tried to remoce all white spaces still giving the problem 

user login id ravi pass ravi

Test script:
---------------
http://www.educationcanvas.com/Travelcorp/index.php

Expected result:
----------------
Warning: Cannot modify header information 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-08-08 20:41 UTC] ajf at ajf dot me
That's a utf-8 site, no?

Maybe you're saving your files as UTF-8 with BOM. This means a UTF-8 encoded file 
with a special byte (or maybe it's a few bytes) at the start to tell the browser 
it's UTF-8. This would obviously break your php code since that would be sent 
before your code. Try saving as UTF8 without BOM. :)
 [2012-08-08 20:44 UTC] nikic@php.net
-Status: Open +Status: Not a bug
 [2012-08-08 20:44 UTC] nikic@php.net
This does not belong in the bug tracker. Ask in some PHP forum. Or better: Don't ask there, because people will be mad at you for asking well-covered, easily-Googleable questions. Here's an extensive reference: http://stackoverflow.com/questions/8028957/headers-already-sent-by-php
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Jan 31 18:03:43 2023 UTC