php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6274 cannot use php_XML_ParserCreate...
Submitted: 2000-08-21 08:09 UTC Modified: 2000-08-26 07:58 UTC
From: opal at lysator dot liu dot se Assigned:
Status: Closed Package: Dynamic loading
PHP Version: 4.0.1pl2 OS: Debian Linux
Private report: No CVE-ID: None
 [2000-08-21 08:09 UTC] opal at lysator dot liu dot se
From: php.ini
-------------
extension=mysql.so
extension=imap.so
extension=ldap.so
extension=xml.so
-------------

/usr/sbin/apache: error in loading shared libraries: /usr/lib/php4/apache/xml.so: undefined symbol: php_XML_ParserCreate

Every time that function is used in a php script. This is quite annoying because I use that function on all my pages...

I use the package from debian woody if you need to reproduce it...

I have reported to the debian maintainer but you might want a bugreport as well.

// Ola

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-23 08:10 UTC] sniper@php.net
Have you tried compiling php4 from sources by yourself?

--Jani
 [2000-08-26 07:58 UTC] sniper@php.net
Leaving --with-xml out fixed this. 

--Jani

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 01 04:01:23 2020 UTC