php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #62719 this extension was not moved to pecl
Submitted: 2012-08-01 19:43 UTC Modified: 2012-08-02 22:57 UTC
From: roberto at spadim dot com dot br Assigned:
Status: Not a bug Package: SQLite (PECL)
PHP Version: 5.4.5 OS: any
Private report: No CVE-ID: None
 [2012-08-01 19:43 UTC] roberto at spadim dot com dot br
Description:
------------
hi guys, checking 
http://php.net/ChangeLog-5.php
at php 5.4.0 part:

Version 5.4.0
01-Mar-2012

Moved extensions to PECL
ext/sqlite. (Note: the ext/sqlite3 and ext/pdo_sqlite extensions are not affected)


sqlite should be at PECL, but it isn´t, any idea where it is?

Test script:
---------------
just don´t exists in pecl...

Expected result:
----------------
should be in pecl...


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-08-02 01:17 UTC] aharvey@php.net
http://pecl.php.net/package/SQLite — there hasn't been a release since it was unbundled from core, but the Subversion repository is up to date.
 [2012-08-02 01:17 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2012-08-02 01:44 UTC] roberto at spadim dot com dot br
nice but just to help guys here in php, where can we find SVN?
 [2012-08-02 01:59 UTC] aharvey@php.net
It's linked on that very page: click "Browse Source".
 [2012-08-02 02:38 UTC] roberto at spadim dot com dot br
is it uptodate? since php 5.3.xxx have the sqlite in source, should the pecl 
source be uptodate with php 5.3 code?
in others words... there´s a sqlite2 version for php5.4? is it planned to exists? 
there´s a lot of code using sqlite2, a port to sqlite3 is a bit hard and time 
consuming
 [2012-08-02 02:53 UTC] aharvey@php.net
My understanding is that it's up to date to what was in php-src at the point 5.4 was branched. Judging by git log, there haven't been any significant changes to the bundled ext/sqlite on the 5.3 branch, so I'd say it's still up to date.

I don't believe there's any plan to actively support the sqlite extension on 5.4+ at this time. You're probably better off talking directly to the maintainers listed on PECL (particularly Philip, since he made the most recent commits) rather than commenting here: they may have future plans, or alternatively, may be interested in finding an active maintainer for the extension.
 [2012-08-02 03:09 UTC] roberto at spadim dot com dot br
ok, sorry about the place that i´m putting comments, i don´t know if exists a IRC 
to talk about it...
there´s a extension conversion give to port 5.3 extension to 5.4 extension? i 
could do it to support sqlite2 in 5.4
 [2012-08-02 03:40 UTC] roberto at spadim dot com dot br
Hi i made the port of php 5.3 to php 5.4 it runs on php 5.3 and php 5.4, could i 
post the new extesion to pecl? it´s running nice for me...
the download link is: http://www.freeupload.com.br/download.php?
file=891sqlite_php5.4.tgz

it´s a free upload site, and worked for me, the md5sum is: 
[root@DELL php-sqlite]# md5sum sqlite-php5.4.tgz
dca02359f8e7e7dc110aaccaa41689b8  sqlite-php5.4.tgz

to compile:
download...
phpize
./configure
make
make install
 [2012-08-02 03:40 UTC] roberto at spadim dot com dot br
the only file that changed is sqlite.c
 [2012-08-02 11:16 UTC] klaus dot pantleon at voith dot com
Sorry, but I cant downoald the file from the freeupload page.
I'm a not registered user and I always get the message "Invalid download link".
Please check the access as unsubscribed user.
 [2012-08-02 14:05 UTC] roberto at spadim dot com dot br
ok i got space in my webserver, but please it´s not a high speedy link :)
http://www.spadim.com.br/sqlite-php5.4.tgz
 [2012-08-02 22:57 UTC] roberto at spadim dot com dot br
closed - duplicate of 
https://bugs.php.net/bug.php?id=57133
 [2012-08-02 22:57 UTC] roberto at spadim dot com dot br
-Type: Documentation Problem +Type: Feature/Change Request
 [2012-08-02 23:08 UTC] roberto at spadim dot com dot br
i removed the old file, i sent a email to philip to consider the new pecl new extension at:

http://www.spadim.com.br/SQLite-1.0.4.tgz
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Nov 17 12:01:34 2019 UTC