php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62708 fpm_sockets.[ch] uses reserved word, "sun"
Submitted: 2012-07-31 19:22 UTC Modified: 2012-07-31 19:25 UTC
From: wongk at apt dot homeunix dot net Assigned:
Status: Duplicate Package: Compile Failure
PHP Version: 5.3.15 OS: Solaris
Private report: No CVE-ID: None
 [2012-07-31 19:22 UTC] wongk at apt dot homeunix dot net
Description:
------------
Solaris has the reserved word, "sun", which is used in sapi/fpm/fpm/fpm_sockets.h 
and sapi/fpm/fpm/fpm_sockets.c

Replacing those instances of "sun" with "s_un" results in a successful compile. 



Test script:
---------------
cd /opt/pkgsrc/www/php-fpm;
bmake


Expected result:
----------------
The compilation should succeed.

Actual result:
--------------
Building via pkgsrc on SmartOS:

In file included from /tmp/pkgsrc/www/php-fpm/work/php-
5.3.15/sapi/fpm/fpm/fpm_sockets.c:25:0:                                                                  
/tmp/pkgsrc/www/php-fpm/work/php-5.3.15/sapi/fpm/fpm/fpm_sockets.h:28:54: error:
 expected ';', ',' or ')' before numeric constant


# uname -a
SunOS pkgsrc.apt.homeunix.net 5.11 joyent_20120726T184637Z i86pc i386 i86pc 
Solaris

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-07-31 19:25 UTC] rasmus@php.net
Dupe of #62654
 [2012-07-31 19:25 UTC] rasmus@php.net
-Status: Open +Status: Duplicate
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Mar 21 05:01:26 2019 UTC