php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62652 Make fails because of missing files
Submitted: 2012-07-24 15:32 UTC Modified: 2012-08-03 12:41 UTC
From: mike at saymikeo dot com Assigned: ab (profile)
Status: Closed Package: Trader (PECL)
PHP Version: 5.3.15 OS: OSX Lion
Private report: No CVE-ID: None
 [2012-07-24 15:32 UTC] mike at saymikeo dot com
Description:
------------
creating libtool
appending configuration tag "CXX" to libtool
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/sh /private/tmp/pear/temp/pear-build-rootpwFTIe/trader-0.2.1/libtool --
mode=compile cc  -I. -I/private/tmp/pear/temp/trader -DPHP_ATOM_INC -
I/private/tmp/pear/temp/pear-build-rootpwFTIe/trader-0.2.1/include -
I/private/tmp/pear/temp/pear-build-rootpwFTIe/trader-0.2.1/main -
I/private/tmp/pear/temp/trader -I/usr/include/php -I/usr/include/php/main -
I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -
I/usr/include/php/ext/date/lib -I/private/tmp/pear/temp/trader/ta-lib/include -
I/private/tmp/pear/temp/trader/ta-lib/src/ta_common -
I/private/tmp/pear/temp/trader/functions  -DHAVE_CONFIG_H  -g -O2   -c 
/private/tmp/pear/temp/trader/ta-lib/src/ta_common/ta_global.c -o ta-
lib/src/ta_common/ta_global.lo
/private/tmp/pear/temp/pear-build-rootpwFTIe/trader-0.2.1/libtool: line 1280: ta-
lib/src/ta_common/ta_global.loT: No such file or directory
mkdir ta-lib/src/ta_common/.libs
mkdir: ta-lib/src/ta_common: No such file or directory
make: *** [ta-lib/src/ta_common/ta_global.lo] Error 1
ERROR: `make' failed
Merges-iMac:etc mike$ which php
/usr/bin/php
Merges-iMac:etc mike$ php -version
PHP 5.3.10 with Suhosin-Patch (cli) (built: Feb 20 2012 22:55:53) 
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies

Test script:
---------------
pecl install trader-beta


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-07-25 01:48 UTC] aharvey@php.net
-Package: Compile Failure +Package: Trader
 [2012-07-30 17:49 UTC] ab@php.net
The package.xml was fixed in trunk. Please test with the next release.
 [2012-07-31 19:56 UTC] ab@php.net
-Status: Open +Status: Feedback
 [2012-07-31 19:56 UTC] ab@php.net
please check if the issue is fixed with the latest release 0.2.2
 [2012-08-03 11:47 UTC] mike at saymikeo dot com
I can confirm that this is fixed.
 [2012-08-03 12:41 UTC] ab@php.net
-Status: Feedback +Status: Closed -Assigned To: +Assigned To: ab
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Apr 23 18:01:26 2019 UTC