php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62621 config.m4 library/include search issues
Submitted: 2012-07-20 17:50 UTC Modified: 2013-10-24 08:37 UTC
Votes:10
Avg. Score:3.2 ± 0.6
Reproduced:2 of 5 (40.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: auroraeosrose@php.net Assigned: laruence (profile)
Status: Closed Package: lua (PECL)
PHP Version: Irrelevant OS: any
Private report: No CVE-ID: None
 [2012-07-20 17:50 UTC] auroraeosrose@php.net
Description:
------------
On systems (Ubuntu) with multiple versions of lua installed to

/usr/include/lua5.1/lua.h
/usr/include/lua5.2/lua.h

or other configurations - the config.m4 does not detect the correct locations for those includes and libraries correctly

this makes pecl install fail without workarounds via symlinks


Patches

configure (last revision 2012-07-20 22:59 UTC by auroraeosrose@php.net)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-07-20 17:50 UTC] laruence@php.net
-Assigned To: +Assigned To: laruence
 [2012-07-20 18:04 UTC] auroraeosrose@php.net
Oh - and there's also an issue of naming for libraries - some libs are using liblua{version}.a (silly ubuntu) as well, so the detection needs to be a little more flexible there as well
 [2012-07-20 22:59 UTC] auroraeosrose@php.net
The following patch has been added/updated:

Patch Name: configure
Revision:   1342825172
URL:        https://bugs.php.net/patch-display.php?bug=62621&patch=configure&revision=1342825172
 [2012-07-20 23:08 UTC] auroraeosrose@php.net
Yeah, the config.m4 had some major issues - on linux you don't need the lua.a file to do the linking - it's better to use the check_library macro

The attached patch will fall back to detecting "versioned" lua libraries as well which should cover ubuntu/debian weirdness as well
 [2013-10-23 17:13 UTC] remi@php.net
This patch also solves configure on Fedora which use
/usr/include/lua.h
/usr/lib64/liblua-5.1.so

Please apply it
 [2013-10-24 08:37 UTC] laruence@php.net
-Status: Assigned +Status: Closed
 [2013-10-24 08:37 UTC] laruence@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 04 19:01:16 2020 UTC