php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #62614 Please update PCRE library to latest version
Submitted: 2012-07-20 00:20 UTC Modified: 2014-03-07 14:33 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:0 (0.0%)
From: danielklein at airpost dot net Assigned: pajoye
Status: Closed Package: PCRE related
PHP Version: 5.4.9 OS:
Private report: No CVE-ID:
 [2012-07-20 00:20 UTC] danielklein at airpost dot net
Description:
------------
PCRE Library Version is 8.12 (15-Jan-2011) as of PHP 5.4.5 (18-Jul-2012). Latest PCRE Library Version is 8.30 (04-Feb-2012). Please update PHP as there have been many improvements.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-12-24 06:10 UTC] danielklein at airpost dot net
-PHP Version: 5.4.5 +PHP Version: 5.4.9
 [2012-12-24 06:10 UTC] danielklein at airpost dot net
Thank you to all the people who helped get PCRE 8.31 into PHP 5.4.9 (& 5.3.19)! Now that PCRE 8.32 has been released, can that make its way into PHP too please? Main improvement (from user comments on previous request) - \X matches a Unicode extended grapheme cluster

Thank you again!
 [2014-03-07 14:04 UTC] narf at devilix dot net
PHP 5.6-alpha2 has PCRE 8.34.
This should be closed.
 [2014-03-07 14:33 UTC] pajoye@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: pajoye
 [2014-03-07 14:33 UTC] pajoye@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 13:02:15 2014 UTC