php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62568 MySQL connect commands do not work
Submitted: 2012-07-15 04:16 UTC Modified: 2012-08-07 19:55 UTC
From: brandonskypimenta at gmail dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: five point three point zero OS: Mac OS X
Private report: No CVE-ID: None
 [2012-07-15 04:16 UTC] brandonskypimenta at gmail dot com
Description:
------------
When you try to run mysql_connect() under MySQL under OS X 10.6.2 with MySQL installed (under PHP 5.3.0), you will get an error saying the MySQL socket file doesn't exist. Here's an example with vBulletin 3.8.5:

mysql_connect(): No such file or directory /path/to/vbulletin/root/includes/class_core.php on line 314

Expected result:
----------------
The database could have connected properly.

Actual result:
--------------
mysql_connect(): No such file or directory /Users/sky/Sites/vb/includes/class_core.php on line 314

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-07-15 04:35 UTC] rasmus@php.net
-Status: Open +Status: Not a bug
 [2012-07-15 04:35 UTC] rasmus@php.net
Nothing PHP can do about that. Your client and server don't match. But we do give 
you an easy work-around by letting you specify the right path using 
http://www.php.net/manual/en/mysql.configuration.php#ini.mysql.default-socket
 [2012-08-07 19:55 UTC] brandonskypimenta at gmail dot com
change php version
 [2012-08-07 19:55 UTC] brandonskypimenta at gmail dot com
-PHP Version: Irrelevant +PHP Version: five point three point zero
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat May 28 05:09:35 2022 UTC