php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62460 php binaries installed as binary.dSYM
Submitted: 2012-07-02 00:51 UTC Modified: 2012-11-21 17:14 UTC
From: phpbugs at adam dot gs Assigned: johannes
Status: Closed Package: *Compile Issues
PHP Version: 5.3.14 OS: OSX 10.8
Private report: No CVE-ID:
 [2012-07-02 00:51 UTC] phpbugs at adam dot gs
Description:
------------
PHP installs the cli/cgi SAPI binaries as binary.dSYM instead of simply "binary"


It seems like this block of code:
      *.c | *.o | *.obj) ;;
inside the configure script (around line 108113) needs to be extended to ignore 
the .dSYM extension.

Test script:
---------------
N/A

Expected result:
----------------
/usr/local/bin/php

Actual result:
--------------
/usr/local/bin/php.dSYM

Patches

Fixed-bug-62460-php-binaries-installed-as-binary.dSY.patch (last revision 2012-07-19 06:29 UTC) by reeze dot xia at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-07-15 17:13 UTC] reeze dot xia at gmail dot com
do you run ./buildconf yourself and which version of autoconf in your box?
 [2012-07-15 20:19 UTC] phpbugs at adam dot gs
I did not run buildconf and doesn't appear osx dev tools installs any autoconf
 [2012-07-18 17:13 UTC] reeze dot xia at gmail dot com
Hi, 
   I can verify this bug. 
here is another case: http://news.php.net/php.internals/61261

and I'v made pull request: https://github.com/php/php-src/pull/135
 [2012-07-18 17:56 UTC] phpbugs at adam dot gs
Perhaps we should just reduce that check to *darwin*? If not its just as likely to break again on 10.9, the *darwin* test seems much simpler in any event.


Interestingly I saw that line and though, "that's not it because it works on 10.7 for me" I just retested and it DOES break on 10.7.
 [2012-07-19 06:32 UTC] reeze dot xia at gmail dot com
Hi, 
  OSX 10.9 haven't exist at all, although *nix os didn't have any extension for
executable. but I'm ok with *darwin* match too.
 [2012-07-19 06:45 UTC] laruence@php.net
-Assigned To: +Assigned To: johannes
 [2012-07-19 06:45 UTC] laruence@php.net
johannes, could you please look at this? 

thanks
 [2012-07-20 02:55 UTC] reeze dot xia at gmail dot com
Hi, 
      The new released PHP-5.3.15 still have this bug. you could use the 
distributed tar package to reproduce.
using google to search php.dSYM there are a lot of result about it.

Thanks
 [2012-08-06 03:28 UTC] stas@php.net
Automatic comment on behalf of reeze.xia@gmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=07ee764e5709dc8d9f26382d8e7438696f5bb834
Log: Fixed bug #62460 (php binaries installed as binary.dSYM)
 [2012-08-06 03:31 UTC] stas@php.net
-Status: Assigned +Status: Closed
 [2012-08-06 03:31 UTC] stas@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.


 [2012-11-18 20:40 UTC] levim@php.net
As someone who is showing up late to the party; is it safe to rename the file 
`php.dSYM` to `php` or should I apply the patch, reconfigure, recompile, etc?
 [2012-11-21 17:14 UTC] reeze@php.net
@levim

Yes, it's ok to just rename it, if you want to run fpm, you may need to rename 
php-cgi too :)
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 12:01:59 2014 UTC