php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #62450 Remove gzgetss and see if anyone notices
Submitted: 2012-06-29 14:36 UTC Modified: 2012-07-06 10:19 UTC
Votes:7
Avg. Score:4.0 ± 1.4
Reproduced:3 of 5 (60.0%)
Same Version:1 (33.3%)
Same OS:1 (33.3%)
From: turnip@php.net Assigned:
Status: Not a bug Package: *General Issues
PHP Version: Irrelevant OS:
Private report: No CVE-ID:
 [2012-06-29 14:36 UTC] turnip@php.net
Description:
------------
This function (http://php.net/manual/en/function.gzgetss.php) has literally never been used by anyone, ever. Besides the fact that it's worthless, no-one has noticed the error ("striped") on the doc page. We should completely remove the function and see if anyone notices.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-07-06 10:19 UTC] johannes@php.net
A typo in a manual page is no reason for a function be removed.

and a quick check shows people are using it:
http://koders.com/default.aspx?s=gzgetss&submit=Search&la=PHP&li=*
First hit: http://koders.com/php/fid5AEBF8DE39EB1BCA59AC00E6C0960369CC4FDD85.aspx?s=gzgetss#L72
 [2012-07-06 10:19 UTC] johannes@php.net
-Status: Open +Status: Not a bug
 [2012-07-11 09:38 UTC] tero dot tasanen at gmail dot com
I must say +1 for this.. even this not a bug, this function is just totally 
pointless. 

@johannes the koders.com search shows that this function has been used in one 
actual 
code file and koders.com covers just about every open source project in the 
word. (and 
not to mention that in the line the behavior of this function might actually 
result in 
unwanted results since it strips the html tags :D)

So I think that it fair to say that this function is not needed by anyone, it's 
pointless and can safely be removed in future php versions.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 00:01:21 2014 UTC