php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62424 fribidi not anymore have fribidi-config
Submitted: 2012-06-26 18:53 UTC Modified: 2013-05-27 07:16 UTC
From: semnanweb at gmail dot com Assigned: behnam (profile)
Status: Closed Package: fribidi (PECL)
PHP Version: 5.4.4 OS: Ubuntu 11.04 64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: semnanweb at gmail dot com
New email:
PHP Version: OS:

 

 [2012-06-26 18:53 UTC] semnanweb at gmail dot com
Description:
------------
During compile my os have not fribidi-config anymore. so how can i compile it?

my current libfribidi installation :
any program like `vlc` use this library for show right to left subtitles.

sweb@sweb-laptop:~/tmp/fribidi-1.0$ apt-cache show libfribidi
N: Unable to locate package libfribidi
E: No packages found
sweb@sweb-laptop:~/tmp/fribidi-1.0$ apt-cache show libfribidi0 libfribidi-dev 
Package: libfribidi-dev
Priority: optional
Section: libdevel
Installed-Size: 424
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian Hebrew Packaging Team <debian-hebrew-package@lists.alioth.debian.org>
Architecture: amd64
Source: fribidi
Version: 0.19.2-1
Depends: libfribidi0 (= 0.19.2-1)
Filename: pool/main/f/fribidi/libfribidi-dev_0.19.2-1_amd64.deb
Size: 79136
MD5sum: 7a7ec94d7d54182872ec6f7f6ffa6596
SHA1: 3352ed3fb7f5003ee5b9876da464c844a19f313c
SHA256: 42f931e0cfd20b9fb19d3c5dedd02f2c64f946ab84147ba3728c0ba315fae4b7
Description: Development files for FreeBidi library
 FriBiDi is a BiDi algorithm implementation for Hebrew and/or Arabic
 languages.
 This package contains the header files and static libraries for the
 FriBidi C library.
Homepage: http://www.fribidi.org/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 18m

Package: libfribidi0
Priority: important
Section: libs
Installed-Size: 196
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian Hebrew Packaging Team <debian-hebrew-package@lists.alioth.debian.org>
Architecture: amd64
Source: fribidi
Version: 0.19.2-1
Depends: libc6 (>= 2.4)
Filename: pool/main/f/fribidi/libfribidi0_0.19.2-1_amd64.deb
Size: 43806
MD5sum: e432a921e858fa15c0b1616a9c62822d
SHA1: 7c71ef203f02542248de985c33b1a5d82fa4582c
SHA256: a89d700b8c537c2f43e6a42f3e379a16a92e26e9045062ca340932b8a518c61b
Description: Free Implementation of the Unicode BiDi algorithm
 FriBiDi is a BiDi algorithm implementation for Hebrew and/or Arabic
 languages.
 This package contains the shared libraries.
Homepage: http://www.fribidi.org/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 18m
Task: minimal


Test script:
---------------
sweb@sweb-laptop:~/tmp/fribidi-1.0$ ./configure
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /usr/local
checking for PHP includes... -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib
checking for PHP extension directory... /usr/local/lib/php/extensions/no-debug-non-zts-20100525
checking for PHP installed headers prefix... /usr/local/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking for FriBidi support... yes, shared
checking for fribidi-config... no
checking for FriBidi version... configure: error: fribidi-config not found.

Expected result:
----------------
Can not complied.


Patches

fribidi-config (last revision 2013-04-01 15:04 UTC by clicky at erebot dot net)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-04-01 15:07 UTC] clicky at erebot dot net
The attached patch makes it possible to configure the package (ie. go past the "phpize" step).
However, compilation will fail afterwards due to changes in fribidi's API. See my other patch in bug #57893 for a fix.
 [2013-05-13 21:19 UTC] behnam@php.net
-Assigned To: +Assigned To: behnam
 [2013-05-13 21:20 UTC] behnam@php.net
It's fixed on my personal git repo. Waiting for the git.php.net repo to push the 
update.
 [2013-05-15 06:36 UTC] behnam@php.net
The PHP extension for GNU FriBidi just got an update (release 1.1) after 10 
years: http://pecl.php.net/package/fribidi

The new PECL package depends on FriBidi >= 0.19.1 and brings back all the 
features the old (deprecated) log2vis API has.

Please let me know if you experience any new issues.
 [2013-05-15 07:21 UTC] semnanweb at gmail dot com
Thankx for support this useful extension.
Will be tested.
 [2013-05-15 08:36 UTC] semnanweb at gmail dot com
this worded fine:
$text = fribidi_log2vis("سلام", FRIBIDI_RTL, FRIBIDI_CHARSET_UTF8);

i will give an error during use this:
$text = fribidi_log2vis("سلام بهنام", FRIBIDI_RTL, FRIBIDI_CHARSET_UTF8);
// Segmentation fault (core dumped)
 [2013-05-16 01:04 UTC] behnam@php.net
Thanks for the report. I can reproduce the bug here, so I will take a look in the 
next couple of days to see what's the root of the problem.
 [2013-05-27 07:15 UTC] behnam@php.net
Okay, this should be fixed in the latest release, version 1.2. Please open a new 
bug if found any bugs.
 [2013-05-27 07:16 UTC] behnam@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 14:03:37 2021 UTC