php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57893 Does not build due to FRIBIDI_CHARSET_UTF8 missing
Submitted: 2007-10-31 08:57 UTC Modified: 2013-05-16 20:51 UTC
From: shot at hot dot pl Assigned: behnam (profile)
Status: Closed Package: fribidi (PECL)
PHP Version: Irrelevant OS: Ubuntu Linux
Private report: No CVE-ID: None
 [2007-10-31 08:57 UTC] shot at hot dot pl
Description:
------------
An attempt to `sudo pecl install fribidi` breaks with errors about missing FRIBIDI_CHARSET_* declarations.

After uncommenting the #ifndef FRIBIDI_CHARSET_UTF8 block in fribidi.c the (repacked) package installs properly.

The system is Ubuntu 7.10, PHP 5.2.3-1ubuntu6, FriBidi 0.10.7-4build1.


Patches

fribidi-constants (last revision 2013-04-01 15:08 UTC by clicky at erebot dot net)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-02-25 04:29 UTC] norman at digitaltoolcompany dot com
Problem persists with Ubuntu 8.04, fribidi 0.10.9-1, php 5.2.4-2ubuntu5.4. Thanks for solution, shot.
 [2013-04-01 15:13 UTC] clicky at erebot dot net
Attached is a patch that fixes the issue (allowing the package to compile/install successfully).

The patch registers both the new charset names and the old ones (e.g. both FRIBIDI_CHAR_SET_UTF8 and FRIBIDI_CHAR_SET_UTF8).
The old FRIBIDI_CHARSET_ISIRI_3342 charset has been removed as it seems that fribidi does not support it anymore.

It also fixes a call to fribidi_log2vis to match the function's current signature.
 [2013-05-13 21:22 UTC] behnam@php.net
-Assigned To: +Assigned To: behnam
 [2013-05-15 06:35 UTC] behnam@php.net
The PHP extension for GNU FriBidi just got an update (release 1.1) after 10 
years: http://pecl.php.net/package/fribidi

The new PECL package depends on FriBidi >= 0.19.1 and brings back all the 
features the old (deprecated) log2vis API has.

Please let me know if you experience any new issues.
 [2013-05-15 06:36 UTC] behnam@php.net
The PHP extension for GNU FriBidi just got an update (release 1.1) after 10 
years: http://pecl.php.net/package/fribidi

The new PECL package depends on FriBidi >= 0.19.1 and brings back all the 
features the old (deprecated) log2vis API has.

Please let me know if you experience any new issues.
 [2013-05-16 20:51 UTC] behnam@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 19:03:38 2021 UTC