php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62335 zlib conflict with gzhandler
Submitted: 2012-06-15 14:32 UTC Modified: 2012-07-24 02:28 UTC
Votes:33
Avg. Score:4.5 ± 0.8
Reproduced:31 of 31 (100.0%)
Same Version:31 (100.0%)
Same OS:7 (22.6%)
From: hajo at csphere dot eu Assigned: mike
Status: Duplicate Package: Zlib related
PHP Version: 5.4.4 OS: Windows 7
Private report: No CVE-ID:
 [2012-06-15 14:32 UTC] hajo at csphere dot eu
Description:
------------
with php 5.3.13, 5.3.14 and 5.4.3 the script is working well while it delivers the following error with php 5.4.4:

ob_start(): output handler 'ob_gzhandler' conflicts with 'zlib output compression'

webserver is nginx 1.2 without deflate mods using php via fcgi

php.ini setting 'zlib.output_compression' is turned off

Test script:
---------------
error_reporting(E_ALL);

$zlib_oc = ini_get('zlib.output_compression');

if(empty($zlib_oc)) {

    ob_start('ob_gzhandler');
}

echo 'test';

Expected result:
----------------
test

Actual result:
--------------
test with the error message attached that was mentioned above

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-06-15 14:35 UTC] hajo at csphere dot eu
there is also a second error message, but that might be clear:

ob_start(): failed to create buffer
 [2012-06-15 14:50 UTC] hajo at csphere dot eu
update: the issue always starts on first refresh, so it might be caused by the fix for bug 60761, just guessing.
 [2012-06-15 16:31 UTC] mtanalin at yandex dot ru
Same error for me with this code:

	ob_start('ob_gzhandler');

Windows 7, Apache 2.4, PHP 5.4.4 thread-safe, "zlib.output_compression" is set to "off" in php.ini.

The bug disappears if I add "php_flag zlib.output_compression off" in .htaccess file of specific host. So, probably, the bug is that global (from php.ini) "zlib.output_compression=off" setting is just _ignored_ in PHP 5.4.4.
 [2012-06-18 13:39 UTC] hajo at csphere dot eu
bug 55544 is about this issue, too. between stable php 5.4.0 and 5.4.3 it was fixed and seems to fail again now.
 [2012-06-21 11:57 UTC] v dot a dot popov at gmail dot com
Seems to be a problem in merging the fix to actual branch, which releases are made of.
This commit:
http://git.php.net/?p=php-src.git;a=commit;h=85a62e9086db7a8ddfcda4ab1279a2439935f8d5
really fixes the problem, but relevant line is not present in php-5.4.3 and php-5.4.4.
 [2012-06-21 13:09 UTC] php at lippe-net dot de
The Error is still there in Debians php 5.4.5-dev.
 [2012-07-05 07:57 UTC] dietmar at gps-tour dot info
Hi,
the Bug was fixed by Mike in this commit:
http://git.php.net/?p=php-
src.git;a=commit;h=85a62e9086db7a8ddfcda4ab1279a2439935f8d5

On the 15th of May, the following commit by mike removed the added line by the 
above commit:
http://git.php.net/?p=php-
src.git;a=commitdiff;h=0ad53bfd7da12a92a46c08e3fff579a15026b88b

I'not shure, if this was realy intended... So maybe mike can take over this 
ticket... Would be great, to have a working ob_gzhandler again in 5.4
 [2012-07-18 07:22 UTC] stas@php.net
-Assigned To: +Assigned To: mike
 [2012-07-18 07:32 UTC] bugs dot php at mohiva dot com
Same problem here with version 5.4.4 and 5.4.5RC1 from php.net. OS is Centos 6.2, webserver is Apache using PHP via php-fpm.

The configuration that I use in php-fmp.conf is:
php_flag[output_buffering] = on
php_flag[zlib.output_compression] = off
php_value[output_handler] = ob_gzhandler
 [2012-07-19 22:47 UTC] hajo at csphere dot eu
checked this bug against the new php versions:

5.3.15 runs well, but 5.4.5 still has this issue.
 [2012-07-24 02:27 UTC] laruence@php.net
-Status: Assigned +Status: Duplicate
 [2012-07-24 02:27 UTC] laruence@php.net
dup to #55544
 [2012-07-24 02:28 UTC] laruence@php.net
dup to #55544
 [2012-07-24 02:28 UTC] laruence@php.net
dup to #55544
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sun Apr 20 19:01:51 2014 UTC