php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62253 Number check bug
Submitted: 2012-06-07 17:57 UTC Modified: 2012-06-08 23:44 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: rophp at live dot it Assigned:
Status: Duplicate Package: *Math Functions
PHP Version: Irrilevante OS: All
Private report: No CVE-ID: None
 [2012-06-07 17:57 UTC] rophp at live dot it
Description:
------------
Hello, when i go to check if the 2 vars are equals with this return 'equal'
also if the end number is different. There is a limit?

Test script:
---------------
$record['xod']="727202440420867488";
$cookiecodiceconnessione="727202440420867484";
if ($record['xod']==$cookiecodiceconnessione)
   {
   echo 'equal';
   }else{
   echo  'not equal';
   }

Expected result:
----------------
not equal

Actual result:
--------------
equal

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-06-08 13:28 UTC] Sjon at hortensius dot net
You should have a look at bug number #43304
 [2012-06-08 23:44 UTC] nikic@php.net
Duplicate of https://bugs.php.net/bug.php?id=54547. This is not really a bug but the development team decided to change the behavior for PHP 5.4.4.
 [2012-06-08 23:44 UTC] nikic@php.net
-Status: Open +Status: Duplicate
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Oct 21 12:03:33 2021 UTC