php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62182 Default Parameter not to be $_GET or $_POST
Submitted: 2012-05-29 11:56 UTC Modified: 2012-05-30 02:24 UTC
From: noel_fb at hotmail dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: Irrelevant OS: Red Hat
Private report: No CVE-ID:
 [2012-05-29 11:56 UTC] noel_fb at hotmail dot com
Description:
------------
Hello.
Try:
function prueba($metodos = array($_GET, $_POST)){
}

or

function prueba($metodos = array($_GET)){
}

ERROR:
Parse error: syntax error, unexpected T_VARIABLE, expecting ')' in /var/www/html/app/xxx/xxx.php on line xx

Test script:
---------------
Try:
function prueba($metodos = array($_GET, $_POST)){
}

or

function prueba($metodos = array($_GET)){
}

ERROR:
Parse error: syntax error, unexpected T_VARIABLE, expecting ')' in /var/www/html/app/xxx/xxx.php on line xx

Expected result:
----------------
Not error


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-05-29 17:12 UTC] nikic@php.net
This has nothing to do with $_GET or $_POST. Default arguments simply can only be static scalars, variables are not allowed in general.
 [2012-05-29 17:16 UTC] noel_fb at hotmail dot com
Oh! I understand.
I'm sory for the fail.

Saludos! from Argentina!
 [2012-05-30 02:24 UTC] laruence@php.net
-Status: Open +Status: Not a bug
 [2012-05-30 02:24 UTC] laruence@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 23 07:02:14 2014 UTC