php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62096 Does not build with spidermonkey 1.7.0
Submitted: 2012-05-21 16:08 UTC Modified: 2017-01-10 08:00 UTC
Votes:9
Avg. Score:4.8 ± 0.4
Reproduced:8 of 9 (88.9%)
Same Version:3 (37.5%)
Same OS:0 (0.0%)
From: php-bugs-2012 at ryandesign dot com Assigned:
Status: Suspended Package: spidermonkey (PECL)
PHP Version: 5.3.13 OS: OS X 10.6.8
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2012-05-21 16:08 UTC] php-bugs-2012 at ryandesign dot com
Description:
------------
spidermonkey.c: In function ‘php_jscontext_object_new_ex’:
spidermonkey.c:154: error: ‘JSVERSION_LATEST’ undeclared (first use in this function)
spidermonkey.c:154: error: (Each undeclared identifier is reported only once
spidermonkey.c:154: error: for each function it appears in.)
make: *** [spidermonkey.lo] Error 1



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-03-04 13:17 UTC] semako dot ua at gmail dot com
I fix it manualy.
1. sudo pecl download spidermonkey
2. tar -xf spidermonkey-1.0.0.tar
3. cd spidermonkey-1.0.0/
4. phpize
5. edit spidermonkey.c
Add to line 152 next:
int JSVERSION_LATEST = 185;
6. Save file
7. ./configure
8. make
9. make install

It should works.
 [2017-01-10 08:00 UTC] kalle@php.net
-Status: Open +Status: Suspended
 [2017-01-10 08:00 UTC] kalle@php.net
Suspending this report as the extension have not had a release for almost 5 years.  Please revive this if the extension once again shows life
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Jun 16 23:01:28 2019 UTC