php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62060 Built-in web server mismatch index files
Submitted: 2012-05-18 16:37 UTC Modified: 2012-05-19 03:50 UTC
From: reeze dot xia at gmail dot com Assigned:
Status: Not a bug Package: Built-in web server
PHP Version: 5.4.3 OS:
Private report: No CVE-ID: None
 [2012-05-18 16:37 UTC] reeze dot xia at gmail dot com
Description:
------------
    When accessing url like :http://localhost/first/second/third/path
Built-in web server will try to find default index files:index.php/html,

1. if the index file didn't exist 
2. it will try to look it reversely:
3. try look it in third and second and first
if any dir have a index.php or index.html, it will be considered as found index 
file. this is the wrong behavior. if path is a dir, if index.php/html not found
it should be 404.


Test script:
---------------
NONE

Expected result:
----------------
index.php in web root without router
/not/found/path should be 404

Actual result:
--------------
HTTP 200

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-05-18 18:04 UTC] reeze dot xia at gmail dot com
I've sent a pull request at: https://github.com/php/php-src/pull/84
 [2012-05-19 03:50 UTC] laruence@php.net
-Status: Open +Status: Not a bug
 [2012-05-19 03:50 UTC] laruence@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

it's not a bug, it's by design,  for supporting PATH_INFO in built
in webserver

  see: https://github.com/php/php-
src/commit/8d467563e2a0ea302f35b95d49408fabb991cbde

thanks
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed May 22 08:01:26 2019 UTC