php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62038 apache2 + fpm is incompatible with mod_cache, mod_mem_cache
Submitted: 2012-05-15 15:43 UTC Modified: 2012-05-23 09:12 UTC
From: Tamaraxo3 at gmail dot com Assigned: fat (profile)
Status: Not a bug Package: FPM related
PHP Version: 5.3.13 OS: Linux
Private report: No CVE-ID: None
 [2012-05-15 15:43 UTC] Tamaraxo3 at gmail dot com
Description:
------------
when you install apache2 and configure php5-fpm

and now so execute
a2enmod mem_cache

modul will be loaded

but apache cache didn't work with FPM

(all request will be handeled by FPM... none where use mem_cache)

Test script:
---------------
after setup try this

<?php
 header('Cache-Control: public, must-revalidate, max-age=300, s-maxage=300');
 echo time();
?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-05-17 17:59 UTC] Tamaraxo3 at gmail dot com
-: svecpetr@svecpetr.com +: Tamaraxo3 at gmail dot com
 [2012-05-20 22:03 UTC] felipe@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: fat
 [2012-05-23 09:12 UTC] fat@php.net
-Status: Assigned +Status: Not a bug
 [2012-05-23 09:12 UTC] fat@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

This has nothing to do with FPM.

It's a misconfiguration of apache mod_cache or a bug in apache mod_cache somehow.
FPM is standalone and communicate with apache though fastcgi protocol.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC