php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62020 php-mysql warning
Submitted: 2012-05-14 11:22 UTC Modified: 2017-04-20 11:09 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: zhanglijiu at gmail dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.3.13 OS: qnx 6.50
Private report: No CVE-ID: None
 [2012-05-14 11:22 UTC] zhanglijiu at gmail dot com
Description:
------------
I have been trying to compile mysql module for php in qnx 6.50. I have installed 
apache 2.2, mysql 5.1, and ap-php successfully compiled 
and running.
When compiling php-mysql i'v noticed this warning:
...
*** Warning: libtool could not satisfy all declared inter-library
*** dependencied of module mysql. Therefore, libtool will create
*** a static module, that should work as long as the dlopenening
*** application is linked with the -dlopen flag
...

In config.log i'v noticed following:
...
configure:11187: checking whether the c++ linker 
(/usr/qnx650/host/qnx6/x86/usr/bin/ntox86-ld) supports shared libraries

configure:12085: result: no
configure:12106: c++ -c -O2 -l/usr/pkg/include -l/usr/pkg/include/mysql -
l/usr/include -l/usr/pkg/include -l/usr/pkg/
include/mysql -l/usr/include conftest.cpp >&5
PKGSRC-WARNING: Something is trying to run the c++ compiler,
PKGSRC-WARNING: but it is not added to USE_LANGUAGES in the package Makefile.
...




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-05-14 17:42 UTC] sixd@php.net
-Package: mSQL related +Package: MySQL related
 [2012-05-16 09:36 UTC] uw@php.net
-Operating System: Mac OS 10.6.8 +Operating System: qnx 6.50
 [2012-12-17 13:25 UTC] samaneh1d1 at gmail dot com
Hello,

I found this thread when I was searching how to install apache on QNX platform.
Since you mentioned that you have successfully compiled and run apache, Would you please help me with it?
It will be a great help for me.

Thanks in advance,
Samaneh
 [2017-04-20 11:09 UTC] fjanisze@php.net
-Status: Open +Status: Not a bug
 [2017-04-20 11:09 UTC] fjanisze@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon May 23 18:05:46 2022 UTC