php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61984 ReleaseSRWLockExclusive missing in KERNEL32.DLL
Submitted: 2012-05-09 16:46 UTC Modified: 2012-12-31 17:44 UTC
Votes:6
Avg. Score:4.5 ± 0.8
Reproduced:6 of 6 (100.0%)
Same Version:5 (83.3%)
Same OS:3 (50.0%)
From: momchil at bojinov dot info Assigned: ab
Status: Closed Package: APC (PECL)
PHP Version: 5.3.13 OS: Windows 2003 32bit
Private report: No CVE-ID:
 [2012-05-09 16:46 UTC] momchil at bojinov dot info
Description:
------------
Downloaded latest APC from here:
http://downloads.php.net/pierre/php_apc-3.1.10-5.3-vc9-x86.zip
the TS version

Worked fine on my Vista PC, but when I tried it on my 2003 server I got an error 
that ReleaseSRWLockExclusive could not be found in Kernel32.dll

Extension can not be loaded.

I can't try the previous version as I could not find download location.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-05-09 16:48 UTC] momchil at bojinov dot info
-Summary: ReleaseSRWLockExclusive missing in KERNEL.DLL +Summary: ReleaseSRWLockExclusive missing in KERNEL32.DLL
 [2012-05-09 16:48 UTC] momchil at bojinov dot info
fixed summary
 [2012-05-16 22:04 UTC] kissifrot at gmail dot com
Same problem on a Windows XP SP3 32 bits. Seems you forgot to add a check for the OS type ;)
 [2012-05-23 03:04 UTC] xiemaomao520 at 163 dot com
The same as 
php version: php5.4.1 ,
php_apc version: php5.4.1.

On a Win XP SP3 32-bits
 [2012-05-23 09:51 UTC] ab@php.net
Hi,

please try the following build:

http://belsky.info/uploads/my/bugz/61984/php_apc-3.1.10-5.3-vc9-x86-xp.zip

This should suite for xp/2003.
 [2012-05-23 09:59 UTC] ab@php.net
-Assigned To: +Assigned To: ab
 [2012-06-11 11:37 UTC] lgynove at 163 dot com
for ab@php.net
use your apc.dll then ...
php_apc.dll doesn't appear to be a valid Zend extension

windows xp
 [2012-06-11 11:44 UTC] lgynove at 163 dot com
done!
use "extension=php_apc.dll" not "zend_extension=php_apc.dll"
 [2012-06-29 08:25 UTC] ab@php.net
-Status: Assigned +Status: Closed
 [2012-06-29 08:25 UTC] ab@php.net
looks like this is solved now :)
 [2012-12-30 22:44 UTC] spenukl at yahoo dot co dot uk
PHP Version 5.4.7, phpinfo() reports PHP Extension Build is API20100525,TS,VC9. So 
using TS php_apc.dll from http://downloads.php.net/pierre/php_apc-3.1.10-5.4-vc9-
x86.zip. Starting Apache gives "The procedure entry point ReleaseSRWLockExclusive 
could not be located in the dynamic link library KERNEL32.dll." and "PHP Startup: 
Unable to load dynamic library '\xampp\php\ext\php_apc.dll' - The specified 
procedure could not be found."
 [2012-12-31 17:44 UTC] ab@php.net
please use the builds from the links above or from windows.php.net/downloads/pecl
 [2012-12-31 18:47 UTC] spenukl at yahoo dot co dot uk
On XP SP3, using TS xampp\php\ext\php_apc.dll first from 
http://belsky.info/uploads/my/bugz/61984/php_apc-3.1.10-5.4-vc9-x86-xp.zip and 
then from http://windows.php.net/downloads/pecl/releases/apc/3.1.13/php_apc-
3.1.13-5.5-ts-vc9-x86.zip - Now there's no error messages but APC doesn't load, 
there's nothing about it in phpinfo(). Apache debug gives: CACHE_ACCEL requested 
but no suitable object cache is present. You may want to install APC.
 [2012-12-31 20:11 UTC] spenukl at yahoo dot co dot uk
I forgot to edit php.ini to uncomment extension=php_apc.dll. Now with php_apc-
3.1.13-5.5-ts-vc9-x86 the error messages is back. With php_apc-3.1.10-5.4-vc9-x86-
xp it gives "Fatal error: require(): Cannot redeclare class profiler in 
\xampp\htdocs\...\includes\AutoLoader.php on line 1145"
 [2012-12-31 20:37 UTC] spenukl at yahoo dot co dot uk
php_apc-3.1.13-5.4-ts-vc9-x86-xp.zip from pecl loads okay into xampp php v5.4.7 ts 
- doesn't get "ReleaseSRWLockExclusive missing in KERNEL32.DLL" message. Thanks.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sun Apr 20 19:01:51 2014 UTC