php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61981 OO API, walk: $suffix_as_key is not working correctly
Submitted: 2012-05-09 11:10 UTC Modified: 2013-12-06 11:52 UTC
Votes:4
Avg. Score:3.5 ± 0.9
Reproduced:3 of 3 (100.0%)
Same Version:1 (33.3%)
Same OS:1 (33.3%)
From: gubin dot gm at yandex dot ru Assigned: lytboris
Status: Closed Package: SNMP related
PHP Version: 5.4.3 OS: *
Private report: No CVE-ID:
 [2012-05-09 11:10 UTC] gubin dot gm at yandex dot ru
Description:
------------
Bag in method SNMP::walk.
The parameter $suffix_as_key not working correctly.

Test script:
---------------
<?php
  $session = new SNMP(SNMP::VERSION_2c, "127.0.0.1", "public");
  $ifDescr = $session->walk(".1.3.6.1.2.1.2.2.1.2", TRUE);
  print_r($ifDescr);
?>

Expected result:
----------------
Array
(
    [1001] => Port 1:1
    [1002] => Port 1:2
    [1003] => Port 1:3
...
)

Actual result:
--------------
Array
(
    [1001] => Port 1:1
    [iso.3.6.1.2.1.2.2.1.2.1002] => Port 1:2
    [iso.3.6.1.2.1.2.2.1.2.1003] => Port 1:3
...
)

Patches

snmp.c.patch (last revision 2013-03-13 20:08 UTC) by lvgb at sina dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-03-17 15:09 UTC] lytboris@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: lytboris
 [2013-03-17 16:28 UTC] lytboris@php.net
-Summary: php5-snmp 5.4.0-3 +Summary: OO API, walk: $suffix_as_key is not working correctly -Operating System: Debian 6.0 +Operating System: *
 [2013-03-17 16:53 UTC] lytboris@php.net
Automatic comment on behalf of lytboris
Revision: http://git.php.net/?p=php-src.git;a=commit;h=44197774c02506be626c85ec60889b58c6c0575e
Log: Fixed bug #61981
 [2013-03-17 16:53 UTC] lytboris@php.net
-Status: Assigned +Status: Closed
 [2013-03-17 16:53 UTC] lytboris@php.net
Automatic comment on behalf of lytboris
Revision: http://git.php.net/?p=php-src.git;a=commit;h=b32405053f5a32d8c4d83f7566f5b414afd3aedb
Log: Fix bug #61981
 [2013-03-17 16:58 UTC] lytboris@php.net
-Status: Closed +Status: Feedback
 [2013-03-17 16:58 UTC] lytboris@php.net
Please try using this snapshot:

  http://snaps.php.net/php5.4-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/


 [2013-09-13 05:44 UTC] lytboris@php.net
-Status: Feedback +Status: No Feedback
 [2013-09-13 05:44 UTC] lytboris@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.


 [2013-12-06 11:37 UTC] temnota dot am at gmail dot com
tested on php 5.4.4 - works.

without patch:

Array
(
    [1] => D-Link DES-3010G R4.30.B20 Port 1
    [iso.3.6.1.2.1.2.2.1.2.2] => D-Link DES-3010G R4.30.B20 Port 2
    [iso.3.6.1.2.1.2.2.1.2.3] => D-Link DES-3010G R4.30.B20 Port 3
    [iso.3.6.1.2.1.2.2.1.2.4] => D-Link DES-3010G R4.30.B20 Port 4
    [iso.3.6.1.2.1.2.2.1.2.5] => D-Link DES-3010G R4.30.B20 Port 5
    [iso.3.6.1.2.1.2.2.1.2.6] => D-Link DES-3010G R4.30.B20 Port 6
    [iso.3.6.1.2.1.2.2.1.2.7] => D-Link DES-3010G R4.30.B20 Port 7
    [iso.3.6.1.2.1.2.2.1.2.8] => D-Link DES-3010G R4.30.B20 Port 8
    [iso.3.6.1.2.1.2.2.1.2.9] => D-Link DES-3010G R4.30.B20 Port 9
    [iso.3.6.1.2.1.2.2.1.2.10] => D-Link DES-3010G R4.30.B20 Port 10
)

with patch:
Array
(
    [1] => D-Link DES-3010G R4.30.B20 Port 1
    [2] => D-Link DES-3010G R4.30.B20 Port 2
    [3] => D-Link DES-3010G R4.30.B20 Port 3
    [4] => D-Link DES-3010G R4.30.B20 Port 4
    [5] => D-Link DES-3010G R4.30.B20 Port 5
    [6] => D-Link DES-3010G R4.30.B20 Port 6
    [7] => D-Link DES-3010G R4.30.B20 Port 7
    [8] => D-Link DES-3010G R4.30.B20 Port 8
    [9] => D-Link DES-3010G R4.30.B20 Port 9
    [10] => D-Link DES-3010G R4.30.B20 Port 10
)

Push patch to main tree.
 [2013-12-06 11:52 UTC] lytboris@php.net
-Status: No Feedback +Status: Closed
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 18:02:13 2014 UTC