php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6181 GPF in PHP4 after page is refreshed/reloaded
Submitted: 2000-08-15 15:29 UTC Modified: 2000-10-20 16:49 UTC
From: jcameron at geocities dot com Assigned:
Status: Closed Package: MSSQL related
PHP Version: 4.0.1pl2 OS: Windows2000
Private report: No CVE-ID: None
 [2000-08-15 15:29 UTC] jcameron at geocities dot com
I'm running a webserver on Windows2000Server/IIs5/Php4.0.1pl2.
PHP is installed in ISAPI Mode. 

The problem I am encountering is caused by refreshing a page with a MSSQL query on it, that simply displayes the results in a table. The two functions that seem to be causing this problem are mssql_get_array (which failes, horrably!) and mssql_get_row. mssql_get_array generally spits out garbage, filling the array I'm placing the data into with junk, causing PHP to GPF, the mssql_get_row seems to work alright, but apon refreshing the page a couple of times (sometimes once, sometimes 2, or 3 times), it causes PHP to GPF. (ex of GPF: PHP has encountered an Access Violation at 77FC9E82)

I'd be happy to send you guys the source code that causes this, but seeing as even the most simple code does it, there should be no need. Drop me an Email if you'd like more information.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-20 16:49 UTC] fmk@php.net
Update to php 4.0.3 or later.

Some general memory issues was fixed.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 00:03:13 2021 UTC