php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61753 Error while compiling
Submitted: 2012-04-17 08:04 UTC Modified: 2015-02-18 07:45 UTC
Votes:21
Avg. Score:4.9 ± 0.4
Reproduced:15 of 18 (83.3%)
Same Version:7 (46.7%)
Same OS:4 (26.7%)
From: hexes at mail dot ru Assigned:
Status: Wont fix Package: Sybase-ct (ctlib) related
PHP Version: 5.3.10 OS: Gentoo linux
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2012-04-17 08:04 UTC] hexes at mail dot ru
Description:
------------
In file included from /home/tmp/portage/dev-lang/php-5.3.10/work/sapis-
build/cli/ext/sybase_ct/php_sybase_ct.h:62:0,
                 from /home/tmp/portage/dev-lang/php-5.3.10/work/sapis-
build/cli/ext/sybase_ct/php_sybase_ct.c:29:
/opt/sybase/OCS-15_0/include/ctpublic.h:269:63: error: expected declaration 
specifiers or ‘...’ before ‘SQLDA’
make: *** [ext/sybase_ct/php_sybase_ct.lo] Error 1
make: *** Waiting for unfinished jobs....
 * ERROR: dev-lang/php-5.3.10 failed (compile phase):
 *   emake failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-09-03 05:28 UTC] hexes at mail dot ru
ls -1 /opt/sybase/OCS-15_0/lib/
libsmapp.a
libsybblk.a
libsybblk_r.a
libsybblk_r.so
libsybblk.so
libsybcomn.a
libsybcomn_r.a
libsybcomn_r.so
libsybcomn.so
libsybcs.a
libsybcs_r.a
libsybcs_r.so
libsybcs.so
libsybct.a
libsybct_r.a
libsybct_r.so
libsybct.so
libsybdb.a
libsybdb.so
libsybdldap.so.15.0.0
libsybdldap.so.15.0.3
libsybfssl.so.15.0.0
libsybfssl.so.15.0.3
libsybintl.a
libsybintl_r.a
libsybintl_r.so
libsybintl.so
libsybskrb.so.15.0.0
libsybskrb.so.15.0.3
libsybtcl.a
libsybtcl_r.a
libsybtcl_r.so
libsybtcl.so
libsybunic.a
libsybunic.so

Guys there is NO libcomn.a, libcs.a, libct.a, libintl.a !!!!

Why php try to find it??!?!?
 [2015-02-18 07:45 UTC] krakjoe@php.net
-Status: Open +Status: Wont fix
 [2015-02-18 07:45 UTC] krakjoe@php.net
The sybase maintainer has backed away from the project, since nobody new has come forward it has been removed in version 7 of PHP.

For this reason, I'm marking the bug as won't fix, it can still be found by any maintainer that might come along and revive sybase as a PECL project.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue May 21 08:01:26 2019 UTC