php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61751 php_register_internal_extensions error
Submitted: 2012-04-17 06:33 UTC Modified: 2015-11-24 22:23 UTC
Votes:10
Avg. Score:4.6 ± 0.5
Reproduced:9 of 9 (100.0%)
Same Version:3 (33.3%)
Same OS:6 (66.7%)
From: worstnitemare at gmail dot com Assigned: kaplan (profile)
Status: Closed Package: Compile Failure
PHP Version: 5.4.0 OS: AIX 5.3
Private report: No CVE-ID: None
 [2012-04-17 06:33 UTC] worstnitemare at gmail dot com
Description:
------------
./configure --prefix=/bp/d01/usr/home/bpw/bin/php \
--with-apxs2=/bp/d01/usr/home/bpw/bin/apache/bin/apxs \
--with-config-file-path=/bp/d01/usr/home/bpw/bin/apache/conf \
--enable-zip \
--with-zlib-dir=/bp/d01/usr/home/bpw/bin/zlib \
--enable-shared \
--with-libxml-dir=/bp/d01/usr/home/bpw/bin/libxml2 \
--with-mysql=mysqlnd \
--with-mysqli=mysqlnd \
--with-mysqli=mysqlnd \
--with-pdo-mysql=mysqlnd \
--with-mcrypt=/bp/d01/usr/home/bpw/bin/libmcrypt \
--enable-mbstring \
--with-curl=/bp/d01/usr/home/bpw/bin/curl \
--with-oci8=/bp/d01/usr/home/bpw/bin/oracle/db/10.2 \
--with-openssl=/bp/d01/usr/home/bpw/bin/openssl \
--with-ldap=/bp/d01/usr/home/bpw/bin/ldap

ld: 0711-319 WARNING: Exported symbol not defined: 
php_register_internal_extensions
ld: 0711-317 ERROR: Undefined symbol: php_register_internal_extensions
collect2: ld returned 8 exit status
make: *** [sapi/cli/php] Error 1


adding "--disable-cli and --disable-cgi" args allows it to compile.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-04-17 06:36 UTC] worstnitemare at gmail dot com
also tried php5.4-201204170330 with the same result.
 [2012-04-20 18:57 UTC] sixd@php.net
Are there any earlier configure errors/warnings?  Check config.log and see what 
is failing.

When configure succeeds, you should have main/internal_functions.c and 
main/internal_functions_cli.c, both declaring php_register_internal_extensions.

Have your configure options worked in previous versions?  See 
https://bugs.php.net/bug.php?id=61450
 [2012-04-20 18:57 UTC] sixd@php.net
-Status: Open +Status: Feedback
 [2012-04-30 00:44 UTC] worstnitemare at gmail dot com
Thanks for the reply...

I have tried shorting down the config to this.

./configure --prefix=/bp/d01/usr/home/bpw/bin/php \
--with-apxs2=/bp/d01/usr/home/bpw/bin/apache/bin/apxs \
--with-config-file-path=/bp/d01/usr/home/bpw/bin/apache/conf \
--enable-zip \
--with-zlib-dir=/bp/d01/usr/home/bpw/bin/zlib \
--enable-shared \
--with-libxml-dir=/bp/d01/usr/home/bpw/bin/libxml2

The config is successful as per previous config but fails on the "make" with the 
same error. I dont believe i made that clear in my original post, sorry.

config.log doesnt appear to reveal any standouts?

Earlier versions were never compiled with CLI support.

I checked the 2 files mentioned and they both have -

PHPAPI int php_register_internal_extensions(TSRMLS_D)
{
	return php_register_extensions(php_builtin_extensions, EXTCOUNT 
TSRMLS_CC);
}

Thanks.
 [2012-04-30 21:15 UTC] sixd@php.net
-Status: Feedback +Status: Open
 [2012-05-18 13:24 UTC] php at manujbhatia dot net
I was having the same issue with 5.4.3 on AIX 6.1. Modifying the generated 
Makefile as below fixed the issue for me:

20c20
< PHP_CLI_OBJS = sapi/cli/php_cli.lo sapi/cli/php_http_parser.lo 
sapi/cli/php_cli_server.lo
---
> PHP_CLI_OBJS = sapi/cli/php_cli.lo sapi/cli/php_http_parser.lo 
sapi/cli/php_cli_server.lo $(PHP_BINARY_OBJS)
24c24
< PHP_CGI_OBJS = sapi/cgi/cgi_main.lo sapi/cgi/fastcgi.lo
---
> PHP_CGI_OBJS = sapi/cgi/cgi_main.lo sapi/cgi/fastcgi.lo 
main/internal_functions.lo
 [2012-06-16 23:55 UTC] worstnitemare at gmail dot com
Hi,

You legend... I had time to make the changes you suggested and everything worked 
a treat.

Thanks heaps as its very much appreciated.
 [2012-10-18 11:12 UTC] thotsaphon_tun at freewillsolutions dot com
Found problem about this too when build PHP5.4.7 with apache2.4.3 on aix7.1tl1sp4

ld: 0711-317 ERROR: Undefined symbol: php_register_internal_extensions
collect2: ld returned 8 exit status
make: *** [sapi/cli/php] Error 1

After modify Makefile like comment  "[2012-05-18 13:24 UTC] php at manujbhatia dot net "
20c20
< PHP_CLI_OBJS = sapi/cli/php_cli.lo sapi/cli/php_http_parser.lo 
sapi/cli/php_cli_server.lo
---
> PHP_CLI_OBJS = sapi/cli/php_cli.lo sapi/cli/php_http_parser.lo 
sapi/cli/php_cli_server.lo $(PHP_BINARY_OBJS)
24c24
< PHP_CGI_OBJS = sapi/cgi/cgi_main.lo sapi/cgi/fastcgi.lo
---
> PHP_CGI_OBJS = sapi/cgi/cgi_main.lo sapi/cgi/fastcgi.lo 
main/internal_functions.lo


make and install succeed :)
 [2012-11-27 15:22 UTC] fhburkha at blue-bird dot com
The solution from php at manujbhatia dot net worked for me!

Building 5.4.9 on AIX 5.3. Thanks very much.
 [2013-01-03 17:51 UTC] kevin dot sample at cpa dot state dot tx dot us
Encountered the same bug with PHP 5.4.10 on AIX 6.1 and the above fix worked perfectly.  Thanks!
 [2014-03-10 15:00 UTC] dreddy at spectraenergy dot com
Same problem building PHP CLI 5.5.9 on AIX 6.1, fix worked great!
 [2015-06-26 09:43 UTC] egav at hotmail dot com
Same problem building PHP CLI 5.6.10 on AIX 7.1. This issue is still open, since 3 years!
 [2015-07-07 03:05 UTC] uncle dot ziba at gmail dot com
bug still exists with 5.6.10 on AIX 6.1 with xlC 12 compiler.
 [2015-11-23 16:47 UTC] kaplan@php.net
Automatic comment on behalf of kaplanlior@gmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=d6b78a351127285c907bc30cab79eed0b7941330
Log: Fixed bug #61751 (SAPI build problem on AIX: Undefined symbol: php_register_internal_extensions)
 [2015-11-23 16:47 UTC] kaplan@php.net
-Status: Open +Status: Closed
 [2015-11-23 17:01 UTC] kaplan@php.net
Automatic comment on behalf of kaplanlior@gmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=d6b78a351127285c907bc30cab79eed0b7941330
Log: Fixed bug #61751 (SAPI build problem on AIX: Undefined symbol: php_register_internal_extensions)
 [2015-11-23 17:03 UTC] kaplan@php.net
Automatic comment on behalf of kaplanlior@gmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=d6b78a351127285c907bc30cab79eed0b7941330
Log: Fixed bug #61751 (SAPI build problem on AIX: Undefined symbol: php_register_internal_extensions)
 [2015-11-24 22:23 UTC] kaplan@php.net
-Assigned To: +Assigned To: kaplan
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC