php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61659 Test ext\spl\tests\bug60082.phpt fails
Submitted: 2012-04-07 11:57 UTC Modified: 2012-04-10 12:06 UTC
From: ab@php.net Assigned: ab
Status: Closed Package: SPL related
PHP Version: 5.3.10 OS: Windows
Private report: No CVE-ID:
 [2012-04-07 11:57 UTC] ab@php.net
Description:
------------
Test diff:

001- Deprecated: Call-time pass-by-reference has been deprecated in %sbug60082.php on line %d
002-

Expected result:
----------------
test pass

Actual result:
--------------
test fail

Patches

61659.diff (last revision 2012-04-07 12:00 UTC) by ab@php.net)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-04-07 12:00 UTC] ab@php.net
The following patch has been added/updated:

Patch Name: 61659.diff
Revision:   1333800000
URL:        https://bugs.php.net/patch-display.php?bug=61659&patch=61659.diff&revision=1333800000
 [2012-04-07 12:02 UTC] ab@php.net
allow_call_time_pass_reference is allowed by default, so enforce it to be off.

the test isn't present in php 5.4 and master, so the issue is php 5.3 only.
 [2012-04-10 02:01 UTC] mattficken@php.net
The patch works for me on Windows 7 and Gentoo Linux (x86 & x64) on php-5-3-r0f180a6.
 [2012-04-10 12:06 UTC] ab@php.net
Automatic comment on behalf of ab
Revision: http://git.php.net/?p=php-src.git;a=commit;h=b2f2e1d6ccf5e4e282799c6639548833d766985a
Log: Fix bug #61659 Test ext\spl\tests\bug60082.phpt fails
 [2012-04-10 12:06 UTC] ab@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: ab
 [2012-04-10 12:06 UTC] ab@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 04:01:55 2014 UTC