php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61648 Cannot install through command "pecl install apd"
Submitted: 2012-04-06 07:38 UTC Modified: 2017-07-25 15:08 UTC
Votes:12
Avg. Score:4.3 ± 0.7
Reproduced:10 of 10 (100.0%)
Same Version:2 (20.0%)
Same OS:0 (0.0%)
From: info at aaroncraig dot com Assigned: kalle (profile)
Status: Closed Package: apd (PECL)
PHP Version: 5.3.10 OS: Centos 5.8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: info at aaroncraig dot com
New email:
PHP Version: OS:

 

 [2012-04-06 07:38 UTC] info at aaroncraig dot com
Description:
------------
On a fresh install of the OS, I cannot install apd.



Test script:
---------------
# pecl install apd
downloading apd-1.0.1.tgz ...
Starting to download apd-1.0.1.tgz (36,643 bytes)
..........done: 36,643 bytes
15 source files, building
running: phpize
Cannot find config.m4.
Make sure that you run '/usr/bin/phpize' in the top level source directory of the module

ERROR: `phpize' failed


Patches

Installer.php.patch (last revision 2012-11-15 12:35 UTC) by paulie4 at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-11-15 12:49 UTC] paulie4 at gmail dot com
Note: The patch I submitted is applied to a pear core file, which on my machine 
was at /usr/share/pear/PEAR/Installer.php, but it's not worth doing, since it then 
fails trying to build. The patch to fix the failed build can be found here: 
https://bugs.php.net/bug.php?id=58798
 [2015-02-26 07:36 UTC] krakjoe@php.net
-Status: Open +Status: Suspended
 [2015-02-26 07:36 UTC] krakjoe@php.net
APD hasn't had a release in 10 years, this means it's source code is way out of sync with modern PHP.

I'm going to mark this bug as suspended, the report can still be found if a maintainer for APD comes forward.

Sorry about the wait.
 [2017-07-25 15:08 UTC] kalle@php.net
-Status: Suspended +Status: Closed -Assigned To: +Assigned To: kalle
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Mon Nov 19 12:01:26 2018 UTC