php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #61601 strftime format does not allow for all lower case month/weekday
Submitted: 2012-04-02 11:47 UTC Modified: 2012-04-03 18:34 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: koen at fotoloog dot org Assigned:
Status: Closed Package: Date/time related
PHP Version: Irrelevant OS: All
Private report: No CVE-ID: None
 [2012-04-02 11:47 UTC] koen at fotoloog dot org
Description:
------------
---
From manual page: http://www.php.net/function.strftime#refsect1-function.strftime-description
---

The usual way of writing the full/abbreviated name of a month or a weekday is with all lower case letters, e.g. 'december' as opposed to 'December'. And 'maandag' as opposed to 'Monday'.

My locale is nl_nl. See http://nl.wikipedia.org/wiki/Hoofdletter_in_de_Nederlandse_spelling#Perioden (in Dutch) for explanation.

Request is to add format parameters for weekdays and months:
maandag;dinsdag;woensdag;donderdag;vrijdag;zaterdag;zondag
januari;februari;maart;april;mei;juni;juli;augustus;september;oktober;november;december

Test script:
---------------
not applicable.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-04-02 11:48 UTC] koen at fotoloog dot org
I wrote "The usual way of writing the full/abbreviated name of a month or a weekday" but I meant to write "The usual way of writing the full/abbreviated name of a month or a weekday *for my locale*..."
 [2012-04-03 16:10 UTC] klaussilveira@php.net
I have noticed that localized month names also come with the first letter in 
lowercase, as opposed to the default behavior in English. Is this what this bug 
report is all about? Your report is a little confusing, since there's already 
parameters to format weekdays and months.
 [2012-04-03 18:34 UTC] koen at fotoloog dot org
oke, seems like I missed the bit in the documentation that says strftime formats according to locale settings.

I just tested on a Linux box (first had to install Dutch language support) AND use setlocal() before calling strftime() and... it worked!

Sorry for wasting your valuable time on this one... I'll close.
 [2012-04-03 18:34 UTC] koen at fotoloog dot org
-Status: Open +Status: Closed
 [2012-04-03 18:34 UTC] koen at fotoloog dot org
Closed as announced.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Dec 12 21:01:26 2018 UTC