php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61566 Fileinfo ext\fileinfo\tests\finfo_file_002.phpt fails
Submitted: 2012-03-30 15:11 UTC Modified: 2013-04-11 13:00 UTC
From: ab@php.net Assigned: ab
Status: Closed Package: *Directory/Filesystem functions
PHP Version: Irrelevant OS: Windows
Private report: No CVE-ID:
 [2012-03-30 15:11 UTC] ab@php.net
Description:
------------
Test diff:

001+
001- array(6) {
002-   ["%s/resources/dir.zip"]=>
003-   string(15) "application/zip"
004-   ["%s/resources/test.bmp"]=>
005-   string(14) "image/x-ms-bmp"
006-   ["%s/resources/test.gif"]=>
007-   string(9) "image/gif"
008-   ["%s/resources/test.jpg"]=>
009-   string(10) "image/jpeg"
010-   ["%s/resources/test.pdf"]=>
011-   string(15) "application/pdf"
012-   ["%s/resources/test.png"]=>
013-   string(9) "image/png"
014- }

Expected result:
----------------
test pass

Actual result:
--------------
test fails

Patches

61566.diff (last revision 2012-04-02 15:07 UTC) by ab@php.net)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-31 10:02 UTC] ab@php.net
The following patch has been added/updated:

Patch Name: 61566.diff
Revision:   1333188169
URL:        https://bugs.php.net/patch-display.php?bug=61566&patch=61566.diff&revision=1333188169
 [2012-04-02 12:58 UTC] ab@php.net
The following patch has been added/updated:

Patch Name: 61566.diff
Revision:   1333371483
URL:        https://bugs.php.net/patch-display.php?bug=61566&patch=61566.diff&revision=1333371483
 [2012-04-02 15:05 UTC] ab@php.net
-PHP Version: 5.3Git-2012-03-30 (Git) +PHP Version: Irrelevant
 [2012-04-02 15:07 UTC] ab@php.net
The following patch has been added/updated:

Patch Name: 61566.diff
Revision:   1333379251
URL:        https://bugs.php.net/patch-display.php?bug=61566&patch=61566.diff&revision=1333379251
 [2012-04-02 15:11 UTC] ab@php.net
The final patch fixes the failure caused by the posix lseek and read versions under windows in cdf_read() . Additionally all the occurences of lseek and read was replaced by _lseek and _reed for windows.
 [2012-04-02 15:57 UTC] ab@php.net
The patch was commited in revisions:

8684fb7facd8f5c1589996c1ebfd782f77c245ff
909713e233704b4ac317ff3bb397cb40a82795b8
 [2013-04-11 13:00 UTC] ab@php.net
Fixed a while ago, closing.
 [2013-04-11 13:00 UTC] ab@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: ab
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 23:01:58 2014 UTC