php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61555 Invalid key in Reflection class
Submitted: 2012-03-29 18:05 UTC Modified: 2012-03-29 18:43 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: tlr at seegno dot com Assigned:
Status: Not a bug Package: Reflection related
PHP Version: 5.4.0 OS: CentOS 6.2
Private report: No CVE-ID: None
 [2012-03-29 18:05 UTC] tlr at seegno dot com
Description:
------------
When creating a new Reflection object the key "name" displays a weird character.

Expected result:
----------------
ReflectionClass Object
 ([name] => Symfony\Bundle\FrameworkBundle\EventListener\SessionListener)


Actual result:
--------------
ReflectionClass Object
 ([namei˜¥] => Symfony\Bundle\FrameworkBundle\EventListener\SessionListener)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-29 18:24 UTC] tlr at seegno dot com
-Status: Open +Status: Closed
 [2012-03-29 18:24 UTC] tlr at seegno dot com
It appears it has to do with the version installed: 
http://blog.famillecollet.com/pages/Config-en
 [2012-03-29 18:43 UTC] cataphract@php.net
-Status: Closed +Status: Not a bug
 [2012-07-02 21:32 UTC] gm dot godlewski at gmail dot com
I've encountered the same problem on 5.4.3.

Script:
-------
<?php

class Foo
{
	public $propertyA;
	public $propertyB;
	protected $propertyC;
	private $propertyD;
}

$class = new ReflectionClass('Foo');

foreach ($class->getProperties() as $property) {
	var_dump($property->getName());
}

CLI:
----
string(9): "propertyA"
string(9): "propertyB"
string(9): "propertyC"
string(9): "propertyD"

APACHE + FCGID:
---------------
boolean false
boolean false
boolean false
boolean false
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 11 15:01:27 2020 UTC