php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61539 grek@pogodzinach.net
Submitted: 2012-03-28 09:38 UTC Modified: 2012-03-29 05:50 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: grek at pogodzinach dot net Assigned:
Status: Not a bug Package: PHAR related
PHP Version: 5.3.10 OS: ubuntu
Private report: No CVE-ID: None
 [2012-03-28 09:38 UTC] grek at pogodzinach dot net
Description:
------------
Hy when i make phar witch compression and web acces (webphar) i dont have acces to uncompreseed files. 

example : 
/test.phar/test/base.css -> in webbrowser i get compresed content

"Ő<ioŰȒŸ­_ћ`Ř0ŠËrlŘ\~c`3›dfX<”Ř’8ŚH......."


(i create phar witch eclipse - export project as phar witch my stub file) but dont think to change somethink

Expected result:
----------------
if web phar can by compresed it must self uncompress files to web acces i think (or mayby webphar send bad headers?  -dont know)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-28 21:15 UTC] cataphract@php.net
-Status: Open +Status: Not a bug
 [2012-03-28 21:15 UTC] cataphract@php.net
Seems to me the webserver is not even invoking the PHP processor. This is a misconfiguration of your http daemon (e.g. Apache), not a PHP issue.
 [2012-03-29 05:50 UTC] grek at pogodzinach dot net
hm this is default ubuntu apache and php configuration (instalation from repo) 
in other server (hostforweb centros vps) same situation : 

see here : http://projektmatura.pl/media3GZ.phar/js/ckeditor/ckeditor.js 

so how to repair it ?
 [2012-03-29 05:50 UTC] grek at pogodzinach dot net
-Summary: compresed webphar problem +Summary: grek@pogodzinach.net
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Aug 09 09:01:24 2020 UTC