php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61515 Cached script shows different result from uncached
Submitted: 2012-03-26 16:45 UTC Modified: 2012-07-20 21:56 UTC
From: jayce53 at yahoo dot com Assigned: ab (profile)
Status: Closed Package: APC (PECL)
PHP Version: 5.4.0 OS: CentOS 6 64bit
Private report: No CVE-ID: None
 [2012-03-26 16:45 UTC] jayce53 at yahoo dot com
Description:
------------
When running with APC 3.1.9, this code produces an error. Without APC it runs as expected.  Works as expected with APC 3.1.9 on PHP 5.3.9.

APC settings:

extension = apc.so
apc.enabled=1



Test script:
---------------
abstract class Dog {
    public abstract function bark();
}
abstract class SmallDog extends Dog {
}
class Charlie extends SmallDog {
    function bark() {
        echo "woof!";
    }
}
$charlie = new Charlie();
$charlie->bark();


Expected result:
----------------
woof!

Actual result:
--------------
Fatal error: Class Charlie contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (Dog::bark) in Unknown on line 0

If the code is changed so that Charlie extends Dog directly AND the SmallDog class is commented out, the error is:

Fatal error: Call to undefined method Charlie::bark() in /disk1/webs/mydomain/www/test.php on line 13



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-07-17 10:15 UTC] ab@php.net
-Status: Open +Status: Feedback
 [2012-07-17 10:15 UTC] ab@php.net
Can you still reproduce this with current 5.4 and APC versions? I can't.
 [2012-07-20 21:56 UTC] ab@php.net
-Status: Feedback +Status: Closed -Assigned To: +Assigned To: ab
 [2012-07-20 21:56 UTC] ab@php.net
This seems to be fixed with the release 3.1.11.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 18 18:01:27 2020 UTC