php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61496 PHP 5.3.6-13ubuntu3.6 with Suhosin-Patch , Xdebug
Submitted: 2012-03-24 13:36 UTC Modified: 2012-03-24 15:23 UTC
From: grek at pogodzinach dot net Assigned:
Status: Not a bug Package: PHAR related
PHP Version: 5.3.10 OS: ubuntu
Private report: No CVE-ID:
 [2012-03-24 13:36 UTC] grek at pogodzinach dot net
Description:
------------
Hy i have problem with phar (webphar)

when i go first time to browser  /dcms3.phar/examle.jpg i see image i click refresh

i see Fatal error: Uncaught exception 'PharException?' with message 'HALT_COMPILER(); must be declared in a phar' in /home/grek/public_html/projektMatura/dcms3.phar on line 8 PharException?: HALT_COMPILER(); must be declared in a phar in /home/grek/public_html/projektMatura/dcms3.phar on line 8 Call Stack: 0.0000 644720 1. {main}() /home/grek/public_html/projektMatura/dcms3.phar:0 0.0001 645432 2. Phar::webPhar() /home/grek/public_html/projektMatura/dcms3.phar:8

- when i uninstall php5-xcache problem gone,

i use ubuntu

PHP 5.3.6-13ubuntu3.6 with Suhosin-Patch (cli) (built: Feb 11 2012 03:26:01) Copyright (c) 1997-2011 The PHP Group Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies

    with XCache v1.3.2, Copyright (c) 2005-2011, by mOo with Xdebug v2.1.0, Copyright (c) 2002-2010, by Derick Rethans

i found suoshin problem so add

suhosin.executor.include.whitelist="phar" to php.ini but problem is connected to xcache i try few times - always same sitation - when xache is installed first page show image (or any other file requestet with webphar acces example  localhost://pharfile.phar/locationinsidephaer/somefile) next refresh fatal error


Expected result:
----------------
i think is big problem i dont find any infio about it, is hard to use phar if they in some servers run in other not (xcache is popular i think)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-24 14:10 UTC] pajoye@php.net
Please try again using no xdebug, xcache or suhosin patches or extension.
 [2012-03-24 14:10 UTC] pajoye@php.net
-Status: Open +Status: Feedback
 [2012-03-24 15:13 UTC] grek at pogodzinach dot net
-Status: Feedback +Status: Open
 [2012-03-24 15:13 UTC] grek at pogodzinach dot net
When i remove xcache phar work fine, 
but when i install xcache sitation is same (i install and uninstall from repo 
apt-get), so is not possible to use phar in serwer with xcache ? (i try add bug 
to xcache bugs (http://xcache.lighttpd.net/) but i cant )
 [2012-03-24 15:23 UTC] pajoye@php.net
-Status: Open +Status: Not a bug
 [2012-03-24 15:23 UTC] pajoye@php.net
Please report bugs to xcache. Thanks,
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 18:02:13 2014 UTC