php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #61406 pecl search and pecl install are confusing with beta packages
Submitted: 2012-03-15 18:47 UTC Modified: 2012-03-15 22:47 UTC
From: ryanpessa at gmail dot com Assigned:
Status: Not a bug Package: PECL (PECL)
PHP Version: 5.4.0 OS: Ubuntu Linux 11.10
Private report: No CVE-ID: None
 [2012-03-15 18:47 UTC] ryanpessa at gmail dot com
Description:
------------
I recently upgraded to PHP 5.4.0 and needed to reinstall the imagick library. When searching for the package, pecl informs me that there is one package available, version 3.1.0RC1 (beta). However, when I try to install, pecl grabs an older version (3.0.1), which is not listed in the search.

After some research, I found out that I needed to append '-beta' to the end of the package name in order to install the beta package. However, this is not a very intuitive system. If you need to specify that you specifically want to install the beta package, then the search results should specifically specify that there is more than one version available, which would clue the user in to the fact that they need to do something special to get the beta version. Just installing an unlisted version is confusing.

Test script:
---------------
pecl search imagick
sudo pecl install imagick

Expected result:
----------------
'search' shows both the stable and beta versions, cluing the user in to the fact that an extra step is required to install the beta. Or at the very least, the version 'install' tries to grab should be the same as the version 'search' returns, one way or another.

Actual result:
--------------
ryan@ryan-laptop:/usr/lib/php5$ pecl search imagick
Retrieving data...0%
Matched packages, channel pecl.php.net:
=======================================
Package Stable/(Latest) Local
imagick 3.1.0RC1 (beta)       Provides a wrapper to the ImageMagick library.

ryan@ryan-laptop:/usr/lib/php5$ sudo pecl install imagick
downloading imagick-3.0.1.tgz ...
Starting to download imagick-3.0.1.tgz (93,920 bytes)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-15 21:42 UTC] pajoye@php.net
-Status: Open +Status: Not a bug
 [2012-03-15 21:42 UTC] pajoye@php.net
Set your preferred state to beta and it will do what you ask.
 [2012-03-15 22:03 UTC] ryanpessa at gmail dot com
Yes, I realize that. Doesn't change the fact that 'search' shows a different version. If that is your recommended solution, then 'search' should show the non-beta version if you haven't set your preferred version to beta.

I think it's pretty rude of you to just close my 'Feature Request' with 'Not a bug' (I realize it's not a bug per-say, that's why I filed it as a feature request instead of a bug) telling me that I'm just doing it wrong. I'm trying to help by pointing out an inconsistency in the way that pecl operates. If you think that inconsistency should remain there, fine, but don't be rude about it.
 [2012-03-15 22:47 UTC] pajoye@php.net
If you like to propose new search or whatever else, then please report a feature 
request or a bug at http://pear.php.net.

Thanks!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Oct 28 12:01:23 2020 UTC