php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #61403 Logs cluttered with "no decode delegate" (can't disable)
Submitted: 2012-03-15 17:08 UTC Modified: 2015-01-18 04:22 UTC
From: spam at ethaniel dot com Assigned:
Status: No Feedback Package: imagick (PECL)
PHP Version: 5.3.10 OS: Debian
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2012-03-15 17:08 UTC] spam at ethaniel dot com
Description:
------------
I resize millions of images per day.

My logs are loaded with the "php5-cgi: no decode delegate for this image format 
`/tmp/magick-XXqc94Zw' @ error/constitute.c/ReadImage/533".

I was trying to catch this error with "try { $img->readImageFile($fp); } catch 
(Exception $e) {}", however it still gets into the logs. 

Any way to disable this error from getting into the logs?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-05-30 20:33 UTC] mkoppanen@php.net
Have you tried setting fastcgi.logging = 0?
 [2012-05-30 22:09 UTC] spam at ethaniel dot com
Tried as you suggested: added fastcgi.loggin=0 to php.ini, restarted fastcgi, 
checked with phpinfo that it's there.

Same result, the error still gets into the logs.
 [2012-05-30 22:10 UTC] spam at ethaniel dot com
sorry, typo. of course, I added "fastcgi.logging" not "login".
 [2012-05-30 22:11 UTC] spam at ethaniel dot com
just to make my comment completely understandable - the problem still persists.
 [2015-01-02 18:20 UTC] Danack at basereality dot com
This issue is not reproducible on PHP 5.6.2 with the latest (3.2.0RC1) version of Imagick and the latest version of ImageMagick (6.9.9-0). i.e. for the code:


try {
    $fp = fopen("./foo.txt", "r");
    $img = new \Imagick();
    $img->readImageFile($fp);
}
catch(\Exception $e) {
    echo "Exception caught ".$e->getMessage();
}

An exception is sent to the browser, but no error message is sent to a log file.

If this is still an issue with the latest version of Imagick, please can you specify how your server is setup, i.e. nginx/apache and some reproduction code that shows the error happening.
 [2015-01-05 02:45 UTC] danack@php.net
-Status: Open +Status: Feedback
 [2015-01-05 02:45 UTC] danack@php.net
Awaiting feedback.
 [2015-01-18 04:22 UTC] pecl-dev at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 24 15:01:23 2021 UTC