php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6138 unknown command line passed to apxs?
Submitted: 2000-08-13 11:41 UTC Modified: 2000-09-04 19:22 UTC
From: nasbo at nasbo dot com Assigned:
Status: Closed Package: Compile Failure
PHP Version: 4.0.1pl2 OS: Linux RH 5.2
Private report: No CVE-ID:
 [2000-08-13 11:41 UTC] nasbo at nasbo dot com
Simple compile:
./configure --with-mysql \
            --with-apxs=/usr/local/apache/bin/apxs

When it gets to config of SAPI modules....

Configuring SAPI modules
checking for AOLserver support... no
checking for Apache module support via DSO through APXS... 
Usage: apxs -g [-S <var>=<val>] -n <modname>
       apxs -q [-S <var>=<val>] <query> ...
       apxs -c [-S <var>=<val>] !!SNIP!!

configure: error: Sorry, I cannot run apxs. Either you need to install Perl or you need to pass the absolute path of apxs by using --with-apxs=/absolute/path/to/apxs

It looks basically like options are being passed to apxs that it is not familiar with!

Chris
nasbo@nasbo.com

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-17 19:17 UTC] sniper@php.net
What is the apache version you're using??

--Jani
 [2000-09-04 19:22 UTC] sniper@php.net
Nod feedback. Please upgrade your Apache to 1.3.12. 
Reopen this bug report if problem still exists with it.

--Jani

 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 16 07:02:02 2014 UTC