php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61365 stem compile error on PHP 5.4.0
Submitted: 2012-03-12 21:52 UTC Modified: 2012-03-25 15:14 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: idexter dot ru at gmail dot com Assigned:
Status: Not a bug Package: stem (PECL)
PHP Version: 5.4.0 OS: MacOSX 10.7.3
Private report: No CVE-ID: None
 [2012-03-12 21:52 UTC] idexter dot ru at gmail dot com
Description:
------------
A stem does not compile on PHP 5.4.0.
To fix this problem replace "function_entry" to "zend_function_entry"
in file "stem.c" at line #23.

Actual result:
--------------
When I try to "make" it. I have some error like this:

/Users/dexter/Sources/stem-1.5.0/stem-1.5.0/stem.c:23: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘stem_functions’
/Users/dexter/Sources/stem-1.5.0/stem-1.5.0/stem.c:101: error: ‘stem_functions’ undeclared here (not in a function)
make: *** [stem.lo] Error 1

Patches

right-stem-patch-for-php5.4 (last revision 2012-03-12 21:56 UTC) by idexter dot ru at gmail dot com)
stem-patch-for-php5.4 (last revision 2012-03-12 21:53 UTC) by idexter dot ru at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-25 15:14 UTC] felipe@php.net
It already has been fixed in the SVN. Thanks.
 [2012-03-25 15:14 UTC] felipe@php.net
-Status: Open +Status: Not a bug
 [2012-03-25 18:37 UTC] ohill@php.net
Version 1.5.1 was packaged with PHP 5.4 fix from SVN.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sat Nov 18 12:03:15 2017 UTC