php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61282 XMLRPC Failure
Submitted: 2012-03-05 01:20 UTC Modified: 2012-03-05 02:42 UTC
From: thephpguru at hotmail dot com Assigned:
Status: Duplicate Package: XMLRPC-EPI related
PHP Version: 5.3.10 OS: Fedora 13
Private report: No CVE-ID: None
 [2012-03-05 01:20 UTC] thephpguru at hotmail dot com
Description:
------------
Approximately 3 years ago I wrote several PHP programs that allow users to connect to the United States Postal Service Server to do things such as validate addresses, obtain shipping rates, track packages, etc. The site in question is:

http://freshsoftware.dyndns.info/scripts_for_sale/usps/

As of PHP 5.2.3 the scripts worked fine. After upgrading my Fedora System to version 13 I had to upgrade to PHP-5.2.17. Under PHP 5.2.17 I was able to get some of the scripts to work but data is still not being collected by the XMLPRC functions and/or contained in an array properly. For example some data is being chopped and/or left off completely. For example follow the form at the link bellow and you will see that data is not being cut off.

http://freshsoftware.dyndns.info/scripts_for_sale/usps/carrier_pickup_1.php?item_num=USPS-1565986&t=computer_software&software_title=php_usps_xml_carrier_pickup/

For example the listing for Mail Service should say “PriorityMail” but it only says “riorityMail”

The Pickup Confirmation is also not being displayed at all. But I was able to echo the confirmation number out in from a function on line 221.


The source code for this file is:

http://freshsoftware.dyndns.info/scripts_for_sale/usps/usps_xml_carrier_pickup_live.phps


In short my complaint is that the XMLRPC and/or ARRAY functions are not working prop. Please help I have tried every thing. My PHPINFO can be found at:

http://freshsoftware.dyndns.info/php/

Please not that when PHP-5.3.10 is installed no data is returned. I get nothing.


Test script:
---------------
http://freshsoftware.dyndns.info/~freshsoftware/scripts_for_sale/usps/usps_xml_carrier_pickup_live.phps

Expected result:
----------------
An echo of the lines 286 to 307

Actual result:
--------------
Split, Incomplete or Chopped data is received

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-05 02:42 UTC] sixd@php.net
-Status: Open +Status: Duplicate
 [2012-03-05 02:42 UTC] sixd@php.net
Dup of bug #61280
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jun 25 06:01:25 2019 UTC