php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61250 php_mysqlnd_config.h not found
Submitted: 2012-03-02 19:25 UTC Modified: 2012-03-03 15:10 UTC
From: iamhiddensomewhere at gmail dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.4.0 OS: Linux 2.6.32-5-amd64
Private report: No CVE-ID: None
 [2012-03-02 19:25 UTC] iamhiddensomewhere at gmail dot com
Description:
------------
Trying to build ext/pdo_mysql or ext/mysqli (phpize && ./configure && make && make 
install) doesn't work (there are various references to ext/mysqlnd which should be 
../mysqlnd) but after fixing those broken references there's a file missing which 
is called from an include statement.

At ext/mysqlnd/mysqlnd_portability.h:40 the file 'php_mysqlnd_config.h' is 
referenced but nowhere to be found. This prevents ext/pdo_mysql or ext/mysqli from 
being built.

Expected result:
----------------
Compiling ext/pdo_mysql or ext/mysqli successfully.

Actual result:
--------------
make fails with (for example)

In file included from /opt/phpfarm/src/php-
5.4.0/ext/mysqli/../mysqlnd/mysqlnd.h:60,
                 from /opt/phpfarm/src/php-
5.4.0/ext/mysqli/php_mysqli_structs.h:42,
                 from /opt/phpfarm/src/php-5.4.0/ext/mysqli/mysqli.c:34:
/opt/phpfarm/src/php-5.4.0/ext/mysqli/../mysqlnd/mysqlnd_portability.h:40:36: 
error: ./php_mysqlnd_config.h: No such file or directory
make: *** [mysqli.lo] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-02 20:38 UTC] iamhiddensomewhere at gmail dot com
mysqlnd wasn't enabled via --enable-mysqlnd, this bug is now invalid.
 [2012-03-02 20:38 UTC] iamhiddensomewhere at gmail dot com
-Status: Open +Status: Closed
 [2012-03-03 15:10 UTC] cataphract@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon May 23 08:05:45 2022 UTC