php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61246 Error when running PHP-FPM
Submitted: 2012-03-02 14:54 UTC Modified: 2012-04-20 01:42 UTC
Votes:12
Avg. Score:4.6 ± 0.8
Reproduced:12 of 12 (100.0%)
Same Version:10 (83.3%)
Same OS:4 (33.3%)
From: osmanungur at gmail dot com Assigned: felipe (profile)
Status: Closed Package: FPM related
PHP Version: 5.4.0 OS: Mac Os X 10.7.3
Private report: No CVE-ID: None
 [2012-03-02 14:54 UTC] osmanungur at gmail dot com
Description:
------------
Hi,

Today i upgraded my php installation to PHP 5.4, when i running PHP-FPM i'm 
getting this error

➜ sudo php-fpm
php-fpm(20297) malloc: *** error for object 0x10aeb5c00: pointer being freed was 
not allocated
*** set a breakpoint in malloc_error_break to debug

FPM still works and responses without problem via Nginx. 
I haven't problem before upgrading PHP (with PHP 5.3.10). I'm running PHP with APC 
3.1.9.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-04 08:05 UTC] rnysmile at yahoo dot com
similar problem in Ubuntu 10.04

# /etc/init.d/php-fpm restart
Gracefully shutting down php-fpm . done
Starting php-fpm *** glibc detected *** /usr/local/sbin/php-fpm: free(): invalid 
pointer: 0x00007f78b5d45118 ***
======= Backtrace: =========
/lib/libc.so.6(+0x775b6)[0x7f78b2e6d5b6]
/lib/libc.so.6(cfree+0x73)[0x7f78b2e73e83]
/usr/local/sbin/php-fpm(destroy_zend_class+0x23d)[0x73953d]
/usr/local/sbin/php-fpm(zend_hash_clean+0x73)[0x74e7e3]
/usr/local/lib/php/extensions/no-debug-non-zts-
20100525/apc.so(apc_interned_strings_shutdown+0x20)[0x7f78b0285460]
/usr/local/lib/php/extensions/no-debug-non-zts-
20100525/apc.so(apc_module_shutdown+0x12a)[0x7f78b027d8fa]
/usr/local/lib/php/extensions/no-debug-non-zts-20100525/apc.so(+0xb07f)
[0x7f78b027407f]
/usr/local/sbin/php-fpm[0x747855]
/usr/local/sbin/php-fpm[0x74e152]
/usr/local/sbin/php-fpm(zend_hash_graceful_reverse_destroy+0x18)[0x74e3e8]
/usr/local/sbin/php-fpm[0x742443]
/usr/local/sbin/php-fpm(php_module_shutdown+0x2d)[0x6e671d]
/usr/local/sbin/php-fpm[0x7f12b9]
/usr/local/sbin/php-fpm[0x7e958e]
/usr/local/sbin/php-fpm[0x7f693a]
/usr/local/sbin/php-fpm[0x7e89c5]
/usr/local/sbin/php-fpm[0x7efb68]
/lib/libc.so.6(__libc_start_main+0xfd)[0x7f78b2e14c4d]
/usr/local/sbin/php-fpm[0x42f989]


No error if disable APC.
 [2012-03-05 10:02 UTC] takida at nm dot ru
I'm experiencing the same bug as the guy with Ubuntu yet on CentOS 5.7 with 
Apache. Same php version, same APC version, almost the same error:
*** glibc detected *** php-fpm: master process (/usr/lib/php-5.4.0-
custom/etc/php-fpm.conf): free(): invalid pointer: 0xb72a1010 ***

What is strange, php-apc was build from source and could not pass the "make test" 
step completely. When disabling APC everything is fine, otherwise php doesn't 
work at all.
 [2012-03-05 10:23 UTC] takida at nm dot ru
If it would help, apache is running as MPM-Prefork. Everything else is pretty 
standard.
 [2012-03-05 21:16 UTC] dancom96 at gmail dot com
Exact same issue with PHP 5.4.0, APC 3.1.9 but on CentOS 6.

Gives error starting PHP-FPM and says failed, but PHP-FPM does actually start and 
APC appears to work fully. (Page generation time goes down to 1/4 of original gen 
time on Wordpress, like my production server)
 [2012-03-06 22:33 UTC] dancom96 at gmail dot com
Seems to be fixed now in latest APC dev http://pecl.php.net/get/APC
 [2012-03-09 16:15 UTC] okspam01 at baimac dot com
Hello

As of 2012-03-09 this bug seems to still be active.

Compiled PHP 5.4.0 with php-fpm
Compiled APC 3.1.9
Added apc.so to php.ini
Restarted php-fpm

Got a full boatload of errors similar in content and flavor to those already posted in these comments. Can post the entire output if needed.
 [2012-03-09 17:26 UTC] rasmus@php.net
okspam01 use APC from svn for now until we get a new APC release out.
 [2012-03-09 23:38 UTC] dancom96 at gmail dot com
I copy pasted the wrong link in my last comment, but the latest SVN APC seems to 
be broken again. I compiled with SVN APC a couple days ago and it worked fine; but 
today I redownloaded it and recompiled, and I now have the same error once again.
 [2012-03-10 13:49 UTC] Jared dot Williams1 at ntlworld dot com
svn head (currently r324037) contains this problem.

Reverted back to r316786 which doesn't.
 [2012-03-10 14:01 UTC] Jared dot Williams1 at ntlworld dot com
Actually r323587 is fine too it seems, but r323990 introduces the problem.
 [2012-03-12 15:34 UTC] Jared dot Williams1 at ntlworld dot com
Problem seems fixed in r324146
 [2012-03-13 15:25 UTC] gonperes at gmail dot com
Greetings.

I just downloaded latest dev version (5.4.1RC1-dev) and i'm still having this 
problem: Starting php-fpm *** glibc detected *** /usr/local/sbin/php-fpm: 
free(): invalid pointer: 0x00002aedda63c698 ***
(...) and a bunch of lines after this (...)

Everything seems to be working though. It's just this annoying error message.

My setup:
'./configure' '--enable-fpm' '--with-fpm-user=www-data' '--with-fpm-group=www-
data' '--with-curl' '--with-gd' '--with-jpeg-dir' '--with-freetype-dir' '--
enable-gd-native-ttf' '--with-mysql=mysqlnd' '--with-mysqli=mysqlnd' '--with-
pear' '--enable-soap' '--with-imap' '--with-imap-ssl' '--with-kerberos' '--
disable-pdo' '--with-zlib' '--with-openssl' '--enable-zip'
make
make install
pecl install apc

Cheers!
 [2012-03-16 08:14 UTC] ben at customerparadigm dot com
Hello,
I am currently running the following setup for PHP:
  --configure-options [--with-libdir=lib64 --with-gd --enable-fpm --with-mcrypt 
-
-with-curl --with-mysql --with-pdo-mysql]
  --version           [5.4.0]
  --vernum            [50400]
I checked out the following APC revision: 324292
From there I recompiled, and re-installed APC. 
Finally, restarted php-fpm and everything is working fine so far!

--Ben Korn
 [2012-03-28 10:09 UTC] wdauchy at gmail dot com
I also have the same problem with debian 5.4.0-3 packages.
Disabling apc (apc.enabled = 0) is a workaround which make php-fpm start.
 [2012-03-28 10:36 UTC] wdauchy at gmail dot com
I also tested with the last revision of apc (r324329 in my case); it fixes the problem. I guess this bug should be considered as fixed.
 [2012-03-31 18:50 UTC] kaplanlior at gmail dot com
Seems like a duplicate of #61238 which was already fixed in APC at revision 324146.
 [2012-04-20 01:42 UTC] felipe@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: felipe
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Feb 24 20:01:27 2020 UTC