php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61063 enable-fpm bugs
Submitted: 2012-02-12 20:36 UTC Modified: 2012-02-12 20:42 UTC
From: hotseason007 at gmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.3.10 OS: centos 5.7
Private report: No CVE-ID: None
 [2012-02-12 20:36 UTC] hotseason007 at gmail dot com
Description:
------------
http://php-fpm.org/downloads/
there is no fpm for 5.3.10 

the feature is EXPERIMENTAL,bug it will make install fail!

cd php-5.3.x
svn co http://svn.php.net/repository/php/php-src/trunk/sapi/fpm sapi/fpm

there is a error 



Test script:
---------------
after installed,there is no sbin/php-fpm!



Expected result:
----------------
Enable fpm ok !

Actual result:
--------------
Enable fpm ok and everything goes right after the patch !

here is more about the patch
https://github.com/Qzi/webstore/wiki

Patches

php-5.3.10-fpm-unofficial-by-Qzi.patch.txt (last revision 2012-02-12 20:39 UTC by hotseason007 at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-02-12 20:42 UTC] rasmus@php.net
-Status: Open +Status: Not a bug
 [2012-02-12 20:42 UTC] rasmus@php.net
FPM ships with the PHP source distribution. Use ./configure --enable-fpm && make 
to build it.
 [2012-02-12 21:11 UTC] hotseason007 at gmail dot com
I know that fpm ships with 5.3.10,but there is compile error,I'm not along !
https://bugs.php.net/bug.php?id=61057
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 04:05:45 2022 UTC