php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61009 max_input_vars
Submitted: 2012-02-08 13:00 UTC Modified: 2012-02-10 11:11 UTC
From: j dot hensoldt at gmx dot de Assigned:
Status: Not a bug Package: PHP options/info functions
PHP Version: 5.3SVN-2012-02-08 (SVN) OS: Debian squeeze
Private report: No CVE-ID: None
 [2012-02-08 13:00 UTC] j dot hensoldt at gmx dot de
Description:
------------
I am using PHP 5.3.3-7+squeeze7 on Debian+Apache2.

I cann´t change the parameter max_input_vars.

<?
ini_set("max_input_vars","5000");
phpinfo();
?>

A change of max_input_vars in php.ini does not work too. phpinfo() displays the correctly changed value, but the internal value of max_input_vars is not changed and is always 1000.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-02-08 13:14 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2012-02-08 13:14 UTC] aharvey@php.net
As http://au2.php.net/manual/en/info.configuration.php says, max_input_vars is PHP_INI_PERDIR, so can't be set with ini_set().
 [2012-02-08 13:37 UTC] j dot hensoldt at gmx dot de
ok, max_input_vars cant´t be set using ini_set().  I did not know that - thanks.

But i cant´t set max_input_vars in php.ini too. phpinfo() displays the correctly changed value (for example max_input_vars=5000), but the array-input-variables with index > 1000 are truncated. (sorry for my english, i hope you can understand me)
 [2012-02-10 11:11 UTC] j dot hensoldt at gmx dot de
SOLVED :-)

It was suhosin. The parameters:

suhosin.get.max_vars
suhosin.post.max_vars 
suhosin.request.max_vars

overwrite max_input_vars in php.ini.
That´s confused.
 [2012-08-18 19:53 UTC] jdeluca2000 at kellogg dot northwestern dot edu
Hello, can you explain how you were able to change the max_input_vars directive?  
Exactly which file did you edit and what is the code needed to change it to 
something other than 1,000?
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Aug 15 13:03:41 2022 UTC