php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60966 extensions not loaded
Submitted: 2012-02-03 11:37 UTC Modified: 2012-02-03 18:20 UTC
From: bugzilla33 at gmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.3SVN-2012-02-03 (snap) OS: win 7
Private report: No CVE-ID: None
 [2012-02-03 11:37 UTC] bugzilla33 at gmail dot com
Description:
------------
RC7 on Win 7:

change php.ini:
extension=php_gd2.dll
extension=php_intl.dll
extension=php_mbstring.dll

run test script

Test script:
---------------
<?php
 phpinfo();
?>

Expected result:
----------------
gd loaded
intl loaded
mbstring loaded

Actual result:
--------------
only mbstring loaded

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-02-03 11:38 UTC] bugzilla33 at gmail dot com
Run as Apache 2.2.21 module.
 [2012-02-03 11:40 UTC] pajoye@php.net
-Status: Open +Status: Not a bug
 [2012-02-03 11:40 UTC] pajoye@php.net
Can you stop to do that please?

There is bug here, you have issues to configure your PHP since weeks now.

Bugs.php.net is not a support channel. Use the mailing lists for that.
 [2012-02-03 11:56 UTC] bugzilla33 at gmail dot com
Can you take to work?
It is known that it is easiest to say that this is not a mistake and lie on.
You have issue to repair since weeks now.

100 times to repeat the error does not occur in the version of RC4.

Do not know how to diagnose?
 [2012-02-03 11:58 UTC] bugzilla33 at gmail dot com
I use the same php.ini.

Binaries from RC4 works
Binaries from RC7 do not work!!!

And this is supposed to be my fault if your problem?
 [2012-02-03 12:08 UTC] olson at php dot com
pajoye is lazy, he'll never check ...
 [2012-02-03 13:41 UTC] pajoye@php.net
Again, I tested under CLI, TS and NTS and Apache.

intl, gd and other extensions load perfectly fine.

@philip keep your useful comment for another location as well, thanks.
 [2012-02-03 13:59 UTC] bugzilla33 at gmail dot com
If you do not believe that this happens for me is can I create a virtual box images with the system and configured php.
 Unfortunately, I do not know how to deliver it to you because it's some 20GB.
 [2012-02-03 18:20 UTC] bugzilla33 at gmail dot com
0. download http://host0001.webd.pl/bugs/php/bug.7z


1. This is http://www.apachelounge.com/download/binaries/httpd-2.2.21-win32.zip


2. And http://windows.php.net/downloads/qa/php-5.4.0RC7-Win32-VC9-x86.zip


3. httpd.conf modifications

   PHPINIDir c:/php54
   LoadModule php5_module c:/php54/php5apache2_2.dll
   AddType application/x-httpd-php .php


4. php.ini (from php.ini-development) modifications

   extension_dir = "c:\php54\ext"

   extension=php_gd2.dll
   extension=php_intl.dll
   extension=php_mbstring.dll


5. Steps to reproduce

   - use Windows 7 (64-bit ?)
   - upack this to c:\ root
   - run install.bat (install Apache service)
   - run start.bat (start Apache service)
   - type in browser http://127.0.0.1/phpinfo.php

6. Expected result

   - gd loaded
   - intl loaded
   - mbstring loaded

7. Actual result
   - only mbstring loaded


8. Tested on two other machines
 [2016-04-29 08:09 UTC] danielklein at airpost dot net
This is definitely a bug, but I can't tell if it's a PHP bug, an Apache bug or a Windows bug. The following page helped me solve it on my local machine:

http://stackoverflow.com/questions/17976764/why-cant-php-on-windows-see-extension-php-intl-dll-even-though-it-exists?rq=1
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon May 23 18:05:46 2022 UTC