php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60862 Fatal error when trying to search the function list
Submitted: 2012-01-23 21:46 UTC Modified: 2012-01-23 21:51 UTC
From: toby at behan dot org dot nz Assigned:
Status: Duplicate Package: Website problem
PHP Version: Irrelevant OS: Windows 7
Private report: No CVE-ID: None
 [2012-01-23 21:46 UTC] toby at behan dot org dot nz
Description:
------------
I'm getting an error when I try and search for a function in the documentation:

To reproduce:

1. Enter 'strnlen' in search bar at top
2. Click arrow to initiate search
3. Takes me to this URL:

http://nz.php.net/search.php?show=quickref&pattern=substr&

With following error:

Warning: include(/www/sites/nz.php.net/include/mirrors.inc) [function.include]: 
failed to open stream: No such file or directory in 
/www/sites/nz.php.net/include/site.inc on line 6

Warning: include() [function.include]: Failed opening 
'/www/sites/nz.php.net/include/mirrors.inc' for inclusion 
(include_path='.:/www/sites/nz.php.net/include') in 
/www/sites/nz.php.net/include/site.inc on line 6

Warning: include(/www/sites/nz.php.net/include/countries.inc) 
[function.include]: failed to open stream: No such file or directory in 
/www/sites/nz.php.net/include/site.inc on line 9

Warning: include() [function.include]: Failed opening 
'/www/sites/nz.php.net/include/countries.inc' for inclusion 
(include_path='.:/www/sites/nz.php.net/include') in 
/www/sites/nz.php.net/include/site.inc on line 9



Test script:
---------------
I'm getting an error when I try and search for a function in the documentation:

To reproduce:

1. Enter 'strnlen' in search bar at top
2. Click arrow to initiate search
3. Takes me to this URL:

http://nz.php.net/search.php?show=quickref&pattern=substr&

With following error:

Warning: include(/www/sites/nz.php.net/include/mirrors.inc) [function.include]: failed to open stream: No such file or directory in /www/sites/nz.php.net/include/site.inc on line 6

Warning: include() [function.include]: Failed opening '/www/sites/nz.php.net/include/mirrors.inc' for inclusion (include_path='.:/www/sites/nz.php.net/include') in /www/sites/nz.php.net/include/site.inc on line 6

Warning: include(/www/sites/nz.php.net/include/countries.inc) [function.include]: failed to open stream: No such file or directory in /www/sites/nz.php.net/include/site.inc on line 9

Warning: include() [function.include]: Failed opening '/www/sites/nz.php.net/include/countries.inc' for inclusion (include_path='.:/www/sites/nz.php.net/include') in /www/sites/nz.php.net/include/site.inc on line 9



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-01-23 21:51 UTC] philip@php.net
-Status: Open +Status: Duplicate
 [2012-01-23 21:51 UTC] philip@php.net
Duplicate of PHP Bug #60854
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Apr 08 04:01:23 2020 UTC