php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60819 wincache_lock() crashes with CLI SAPI
Submitted: 2012-01-20 14:02 UTC Modified: 2014-05-05 23:55 UTC
From: boen dot robot at gmail dot com Assigned: ericsten (profile)
Status: Closed Package: WinCache (PECL)
PHP Version: 5.3.9 OS: Windows Server 2008 R2
Private report: No CVE-ID: None
 [2012-01-20 14:02 UTC] boen dot robot at gmail dot com
Description:
------------
Using WinCache 1.1.0 VC9 NTS x86, equivalent PHP 5.3.9 version (reproducable on 5.3.8 too). Windows has all updates to date (in case that's relevant).

Any call to wincache_lock() crashes PHP. I've tested this when running PHP from CLI. I don't know if it applies on other SAPIs as well, but even if it doesn't, the CLI is a vital SAPI, because it is used by both PHPUnit and PHPT, so because of this crash, any code calling wincache_lock() is currently untestable in any (automated) way.

Wincache is the only enabled extension requred for the test code below to cause a crash on CLI.

I'm not sure how I can get detailed information on the crash, as the crash window just says it will notify me for solutions and asks me to close.

Test script:
---------------
<?php
wincache_lock('w');
wincache_unlock('w');
?>

Expected result:
----------------
A silent exit with no crashes.

Actual result:
--------------
PHP crashes.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-01-22 19:40 UTC] rasmus@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: ruslany
 [2014-05-05 23:55 UTC] ericsten@php.net
-Status: Assigned +Status: Closed -Assigned To: ruslany +Assigned To: ericsten
 [2014-05-05 23:55 UTC] ericsten@php.net
Just tried this on php5.5 + wincache 1.3.5.4, and I'm unable to repro the bug with the script provided.  No crash observed.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Jul 17 10:01:26 2019 UTC