php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60670 When under load, PHP-FPM master process silently crashes
Submitted: 2012-01-06 13:35 UTC Modified: 2012-01-11 09:53 UTC
From: gwenmael dot rouxel at neovote dot com Assigned:
Status: Closed Package: FPM related
PHP Version: 5.3.8 OS: Debian Lenny
Private report: No CVE-ID: None
 [2012-01-06 13:35 UTC] gwenmael dot rouxel at neovote dot com
Description:
------------
I ran some load tests on a virtual machine which has 16GB ram and four 8Ghz VCores. 

The tests were run using JMeter.
When ~300 simultaneous connections (10 request loop per connection) to FPM exist (through NGinx), The master process crashes and I get 502 errors. The remaining child processes continue executing their scripts then terminate.

I use a static pool configuration, and no matter what the child processes number is, it crashes.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-01-06 13:44 UTC] fat@php.net
-Status: Open +Status: Feedback
 [2012-01-06 13:44 UTC] fat@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2012-01-11 09:53 UTC] gwenmael dot rouxel at neovote dot com
I am unable to reproduce the crash for now, so I cannot provide dumps or a backtrace. If it happens again, though, I'll do.

Thanks for your time.
 [2012-01-11 09:53 UTC] gwenmael dot rouxel at neovote dot com
-Status: Feedback +Status: Closed
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 20 17:03:35 2021 UTC