php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #60656 our PHP MySQL library version XXX differs from your MySQL server version YYY
Submitted: 2012-01-04 15:47 UTC Modified: -
Votes:18
Avg. Score:4.2 ± 1.0
Reproduced:17 of 17 (100.0%)
Same Version:9 (52.9%)
Same OS:3 (17.6%)
From: e dot a dot botjes at gmail dot com Assigned:
Status: Open Package: Dynamic loading
PHP Version: Irrelevant OS: Linux / Ububtu 10.4
Private report: No CVE-ID:
Have you experienced this issue?
Rate the importance of this bug to you:

 [2012-01-04 15:47 UTC] e dot a dot botjes at gmail dot com
Description:
------------
I run:
Ubuntu 10.4
PhpMyAdmin 3.4.8
PHP 5.3.2-1ubuntu4.11 
MariaDB 5.3.3

I upgraded from mariadb 5.2.?

Since this upgrade I get the following warning in phpmyadmin:
"Your PHP MySQL library version 5.2.10-MariaDB differs from your MySQL server 
version 5.3.3. This may cause unpredictable behavior."

When previously upgrading from mysql 5.? to mariadb 5.2.? I also recieved this 
warning.

The first time I fixed this by using "apt-get install php5-mysql"
But the second time this did not work.

According to http://www.dotdeb.org/2011/11/01/mysql-5-5-is-finally-here/
the version differs can be ignored.

According to a chat on freenode #maria
...
[15:56] <wlad> edzob, I do not think so. I think the correct place to complain 
in this case is PHP. This PHP version check is just pointless, just does not 
work. This will not cause unpredictable behavior
...
[16:06] <wlad> edzob, it was done by a nice guy indeed, it is done  wrong.. He 
(person who introduced the check) said that long ago in  a galaxy far away, ABI 
or protocol was changed between some of 5.0 releases. And since then he became 
overcautiious. Pierre might know more details to it, and may be (I don't know 
for sure) even has an influence on it in a way that the check is finally removed 
for good.

Thus my request..
Since 2 sources state that the warning can be ignored.
Can this version check be removed from php?
So that this warning without a function (or functional impact as reason) does 
not give this warning anymore?
 


Patches

Add a Patch

Pull Requests

Add a Pull Request

 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 02:02:11 2014 UTC